summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-11 21:13:38 +0100
committerSam James <sam@gentoo.org>2023-07-11 21:13:48 +0100
commit62889088610bcc9df25bd1529ce6a3f19b6392a3 (patch)
tree66926a33d92b49c7c275da640c744d0a4fa3ae8a /dev-util/meson
parentdev-util/meson: add 1.2.0_rc3 (diff)
downloadgentoo-62889088610bcc9df25bd1529ce6a3f19b6392a3.tar.gz
gentoo-62889088610bcc9df25bd1529ce6a3f19b6392a3.tar.bz2
gentoo-62889088610bcc9df25bd1529ce6a3f19b6392a3.zip
dev-util/meson: drop 1.2.0_rc1, 1.2.0_rc2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/meson')
-rw-r--r--dev-util/meson/Manifest2
-rw-r--r--dev-util/meson/meson-1.2.0_rc1.ebuild117
-rw-r--r--dev-util/meson/meson-1.2.0_rc2.ebuild117
3 files changed, 0 insertions, 236 deletions
diff --git a/dev-util/meson/Manifest b/dev-util/meson/Manifest
index 3f74f61f04f1..b8fa06613693 100644
--- a/dev-util/meson/Manifest
+++ b/dev-util/meson/Manifest
@@ -1,4 +1,2 @@
DIST meson-1.1.1.tar.gz 2125503 BLAKE2B 295b46d19c8a1d64d326a6c826e2abe11d9768902ed2f8816df18677e7f3f58decc0c660925821825ecd9a4955a65bda8b2aa66a7bb1961810d8f78f92a3fd8a SHA512 c6259d73566d2532b87e8a23951363103f7be2aacdf120e50946273a2fed6b1602104a3ffbfda159138ac8f780d2c3e67a6fe2c8c228b73c1266775491797adb
-DIST meson-1.2.0rc1.tar.gz 2176016 BLAKE2B c7c19b5fe8e25964dbdacaf7b2aa8e348e81e387f79b9576c6d8541064cd499008d70b527299eb02280828b7c1f91b194f2c6d2e54f702295b52b5d7a24c5d3f SHA512 2511b40a8cc55093758599e3e51926a5ccac16c92a5bd33239c743fa6926af9ba0f7508dd2f04adbb2c4599ebad5d34f1a2e112d7ac10dd211e9511522d23962
-DIST meson-1.2.0rc2.tar.gz 2173996 BLAKE2B 99707e8d57a95ed9ee381f05e5c22a5f73433a472c5dcad25999af8cb4c7a52d4604eee260e22a84cc2fff402fed0a57d0263f7e43e4986482c49b73f06920e0 SHA512 3090d33e0b4b695f407ebc196ad5508c1f617cdb04d97f265e7e13d12baa568273b04c4c0dbd8cb9a6a19fe1fec2047698bd3a4ea62929637887d835edcc6eac
DIST meson-1.2.0rc3.tar.gz 2179074 BLAKE2B a195ccbc2fdf601ec7a0bbc4d858f04b37a843be4705e58f40274ada82615b63fd02f0e681138595d122bce76e274d69c6937247a578ae6bd76d71329693aa9d SHA512 af2659d88d8b8db46c4b96a6c6b2da0ee71899600f8c6a65d1086503d3ee003b28f2ab37782bf678a7f90d6be5f2de10f7032e002008b57136b8f905b90dd5dc
diff --git a/dev-util/meson/meson-1.2.0_rc1.ebuild b/dev-util/meson/meson-1.2.0_rc1.ebuild
deleted file mode 100644
index fefd68d177e5..000000000000
--- a/dev-util/meson/meson-1.2.0_rc1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 2016-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mesonbuild/meson"
- inherit git-r3
-else
- inherit pypi
-
- MY_P=${P/_/}
- S=${WORKDIR}/${MY_P}
-
- if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
- fi
-fi
-
-inherit bash-completion-r1 distutils-r1 toolchain-funcs
-
-DESCRIPTION="Open source build system"
-HOMEPAGE="https://mesonbuild.com/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/glib:2
- dev-libs/gobject-introspection
- dev-util/ninja
- dev-vcs/git
- sys-libs/zlib[static-libs(+)]
- virtual/pkgconfig
- )
-"
-RDEPEND="
- virtual/pkgconfig
-"
-
-python_prepare_all() {
- local disable_unittests=(
- # ASAN and sandbox both want control over LD_PRELOAD
- # https://bugs.gentoo.org/673016
- -e 's/test_generate_gir_with_address_sanitizer/_&/'
-
- # ASAN is unsupported on some targets
- # https://bugs.gentoo.org/692822
- -e 's/test_pch_with_address_sanitizer/_&/'
-
- # https://github.com/mesonbuild/meson/issues/7203
- -e 's/test_templates/_&/'
-
- # Broken due to python2 wrapper
- -e 's/test_python_module/_&/'
- )
-
- sed -i "${disable_unittests[@]}" unittests/*.py || die
-
- # Broken due to python2 script created by python_wrapper_setup
- rm -r "test cases/frameworks/1 boost" || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- tc-export PKG_CONFIG
- if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then
- ewarn "Found Qt5Core but not Qt5Gui; skipping tests"
- else
- distutils-r1_src_test
- fi
-}
-
-python_test() {
- (
- # test_meson_installed
- unset PYTHONDONTWRITEBYTECODE
-
- # https://bugs.gentoo.org/687792
- unset PKG_CONFIG
-
- # test_cross_file_system_paths
- unset XDG_DATA_HOME
-
- # 'test cases/unit/73 summary' expects 80 columns
- export COLUMNS=80
-
- # If JAVA_HOME is not set, meson looks for javac in PATH.
- # If javac is in /usr/bin, meson assumes /usr/include is a valid
- # JDK include path. Setting JAVA_HOME works around this broken
- # autodetection. If no JDK is installed, we should end up with an empty
- # value in JAVA_HOME, and the tests should get skipped.
- export JAVA_HOME=$(java-config -O 2>/dev/null)
-
- # Call python3 instead of EPYTHON to satisfy test_meson_uninstalled.
- python3 run_tests.py
- ) || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles
- doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
-
- insinto /usr/share/zsh/site-functions
- doins data/shell-completions/zsh/_meson
-
- dobashcomp data/shell-completions/bash/meson
-}
diff --git a/dev-util/meson/meson-1.2.0_rc2.ebuild b/dev-util/meson/meson-1.2.0_rc2.ebuild
deleted file mode 100644
index fefd68d177e5..000000000000
--- a/dev-util/meson/meson-1.2.0_rc2.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 2016-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mesonbuild/meson"
- inherit git-r3
-else
- inherit pypi
-
- MY_P=${P/_/}
- S=${WORKDIR}/${MY_P}
-
- if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
- fi
-fi
-
-inherit bash-completion-r1 distutils-r1 toolchain-funcs
-
-DESCRIPTION="Open source build system"
-HOMEPAGE="https://mesonbuild.com/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/glib:2
- dev-libs/gobject-introspection
- dev-util/ninja
- dev-vcs/git
- sys-libs/zlib[static-libs(+)]
- virtual/pkgconfig
- )
-"
-RDEPEND="
- virtual/pkgconfig
-"
-
-python_prepare_all() {
- local disable_unittests=(
- # ASAN and sandbox both want control over LD_PRELOAD
- # https://bugs.gentoo.org/673016
- -e 's/test_generate_gir_with_address_sanitizer/_&/'
-
- # ASAN is unsupported on some targets
- # https://bugs.gentoo.org/692822
- -e 's/test_pch_with_address_sanitizer/_&/'
-
- # https://github.com/mesonbuild/meson/issues/7203
- -e 's/test_templates/_&/'
-
- # Broken due to python2 wrapper
- -e 's/test_python_module/_&/'
- )
-
- sed -i "${disable_unittests[@]}" unittests/*.py || die
-
- # Broken due to python2 script created by python_wrapper_setup
- rm -r "test cases/frameworks/1 boost" || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- tc-export PKG_CONFIG
- if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then
- ewarn "Found Qt5Core but not Qt5Gui; skipping tests"
- else
- distutils-r1_src_test
- fi
-}
-
-python_test() {
- (
- # test_meson_installed
- unset PYTHONDONTWRITEBYTECODE
-
- # https://bugs.gentoo.org/687792
- unset PKG_CONFIG
-
- # test_cross_file_system_paths
- unset XDG_DATA_HOME
-
- # 'test cases/unit/73 summary' expects 80 columns
- export COLUMNS=80
-
- # If JAVA_HOME is not set, meson looks for javac in PATH.
- # If javac is in /usr/bin, meson assumes /usr/include is a valid
- # JDK include path. Setting JAVA_HOME works around this broken
- # autodetection. If no JDK is installed, we should end up with an empty
- # value in JAVA_HOME, and the tests should get skipped.
- export JAVA_HOME=$(java-config -O 2>/dev/null)
-
- # Call python3 instead of EPYTHON to satisfy test_meson_uninstalled.
- python3 run_tests.py
- ) || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles
- doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
-
- insinto /usr/share/zsh/site-functions
- doins data/shell-completions/zsh/_meson
-
- dobashcomp data/shell-completions/bash/meson
-}