summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-22 02:28:36 +0000
committerSam James <sam@gentoo.org>2022-12-22 02:28:36 +0000
commitac7a50dc4fbb1de933dbc6bbcb26694995cd629b (patch)
tree638a45edb88fbb216155eae31cf7e03f69d84cb3 /dev-util/heaptrack
parentnet-dns/bind-tools: add 9.16.36 (diff)
downloadgentoo-ac7a50dc4fbb1de933dbc6bbcb26694995cd629b.tar.gz
gentoo-ac7a50dc4fbb1de933dbc6bbcb26694995cd629b.tar.bz2
gentoo-ac7a50dc4fbb1de933dbc6bbcb26694995cd629b.zip
dev-util/heaptrack: fix build w/ boost 1.81
Closes: https://bugs.gentoo.org/887033 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/heaptrack')
-rw-r--r--dev-util/heaptrack/files/heaptrack-1.4.0-boost-1.81.patch23
-rw-r--r--dev-util/heaptrack/heaptrack-1.4.0.ebuild4
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/heaptrack/files/heaptrack-1.4.0-boost-1.81.patch b/dev-util/heaptrack/files/heaptrack-1.4.0-boost-1.81.patch
new file mode 100644
index 000000000000..564f0925a9be
--- /dev/null
+++ b/dev-util/heaptrack/files/heaptrack-1.4.0-boost-1.81.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/887033
+https://invent.kde.org/sdk/heaptrack/-/commit/de3174aa1d1293636079473ff693d9a274a093a9
+
+From de3174aa1d1293636079473ff693d9a274a093a9 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heiko.becker@kde.org>
+Date: Fri, 16 Dec 2022 00:01:15 +0100
+Subject: [PATCH] Add missing include
+
+This fixes the build with boost 1.81.0. <array> was included by one of
+the boost headers, however, it's no longer included as of Boost 1.81.0.
+--- a/src/analyze/gui/histogrammodel.h
++++ b/src/analyze/gui/histogrammodel.h
+@@ -9,6 +9,8 @@
+
+ #include <QAbstractTableModel>
+
++#include <array>
++
+ #include "treemodel.h"
+
+ struct HistogramColumn
+--
+GitLab
diff --git a/dev-util/heaptrack/heaptrack-1.4.0.ebuild b/dev-util/heaptrack/heaptrack-1.4.0.ebuild
index fd9b0ba63961..29eec26eb107 100644
--- a/dev-util/heaptrack/heaptrack-1.4.0.ebuild
+++ b/dev-util/heaptrack/heaptrack-1.4.0.ebuild
@@ -44,6 +44,10 @@ BDEPEND="
gui? ( kde-frameworks/extra-cmake-modules:5 )
"
+PATCHES=(
+ "${FILESDIR}"/${P}-boost-1.81.patch # bug #887033, in master
+)
+
src_prepare() {
cmake_src_prepare
rm -rf 3rdparty/boost-zstd || die # ensure no bundling