summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cpputest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cpputest')
-rw-r--r--dev-util/cpputest/Manifest2
-rw-r--r--dev-util/cpputest/cpputest-3.6.ebuild24
-rw-r--r--dev-util/cpputest/cpputest-3.7.2.ebuild24
-rw-r--r--dev-util/cpputest/metadata.xml11
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/cpputest/Manifest b/dev-util/cpputest/Manifest
new file mode 100644
index 000000000000..68f303061241
--- /dev/null
+++ b/dev-util/cpputest/Manifest
@@ -0,0 +1,2 @@
+DIST cpputest-3.6.tar.gz 2674015 SHA256 1d5b745322f36569536bad2dd41fe0e74b208da6475d6a1bfb0c2cb1adeefbbb SHA512 3bd160b6735a818534681643c613fba28b8a64debb7f1e2fa037d94a81b875710b54b9bc5e7d18b4d40258beae1b12202628cf1b4673107770587e07bc6624e4 WHIRLPOOL 9ebe1c462d446bfae391a254dab613d58209e6c67f80169da982ba00673b0a3ab8a4724ab048e213b2d5885fd6464c1ef35c1e76933e35d66cab741433f8f310
+DIST cpputest-3.7.2.tar.gz 2750879 SHA256 8c5d00be3a08ea580e51e5cfe26f05d05c6bf546206ff67dbb3757d48c109653 SHA512 4a958cd61cb8f1a03a308fa001c57fbc58841582606856efda506f2108e26f720928350c81c2883a233c477107f01786f286a106e6520717714d56da764fbd88 WHIRLPOOL 7ac78207b5e8e5d231fa3ecd3dd71282bbd73ba8ed36401b34daa9cd41e60a4e4db4f0c6d9df802938cc0a5d3ee6afb2c21b0de74fa474384dfdca776df95bf1
diff --git a/dev-util/cpputest/cpputest-3.6.ebuild b/dev-util/cpputest/cpputest-3.6.ebuild
new file mode 100644
index 000000000000..c92b228de8f8
--- /dev/null
+++ b/dev-util/cpputest/cpputest-3.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils
+
+DESCRIPTION="unit testing and mocking framework for C/C++"
+HOMEPAGE="http://cpputest.github.io/ https://github.com/cpputest/cpputest"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-cpp/gmock
+ dev-cpp/gtest
+ )
+"
+
+DOCS=( AUTHORS README.md README_CppUTest_for_C.txt )
diff --git a/dev-util/cpputest/cpputest-3.7.2.ebuild b/dev-util/cpputest/cpputest-3.7.2.ebuild
new file mode 100644
index 000000000000..f5f12570b54a
--- /dev/null
+++ b/dev-util/cpputest/cpputest-3.7.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils
+
+DESCRIPTION="unit testing and mocking framework for C/C++"
+HOMEPAGE="http://cpputest.github.io/ https://github.com/cpputest/cpputest"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-cpp/gmock
+ dev-cpp/gtest
+ )
+"
+
+DOCS=( AUTHORS README.md README_CppUTest_for_C.txt )
diff --git a/dev-util/cpputest/metadata.xml b/dev-util/cpputest/metadata.xml
new file mode 100644
index 000000000000..43eb70620e84
--- /dev/null
+++ b/dev-util/cpputest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cpputest/cpputest</remote-id>
+ </upstream>
+</pkgmetadata>