summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-06-17 09:28:23 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-06-17 09:28:23 -0400
commit46c3c10815f5a3cc307d8e37b9522b91138f699e (patch)
tree4552327da0e1ea9be078602a83d5919b553dd446 /dev-util/comparator/comparator-2.12.ebuild
parentnet-misc/electrum: RDEPEND on >=dev-python/aiorpcX-0.17, bug #687004 (diff)
downloadgentoo-46c3c10815f5a3cc307d8e37b9522b91138f699e.tar.gz
gentoo-46c3c10815f5a3cc307d8e37b9522b91138f699e.tar.bz2
gentoo-46c3c10815f5a3cc307d8e37b9522b91138f699e.zip
dev-util/comparator: version bump to 2.12
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-util/comparator/comparator-2.12.ebuild')
-rw-r--r--dev-util/comparator/comparator-2.12.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/comparator/comparator-2.12.ebuild b/dev-util/comparator/comparator-2.12.ebuild
new file mode 100644
index 000000000000..bbbbe0a4134a
--- /dev/null
+++ b/dev-util/comparator/comparator-2.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=app-text/docbook-xml-dtd-4.1.2*
+ app-text/xmlto"
+
+src_prepare() {
+ sed \
+ -e '/python setup.py install/d' \
+ -i Makefile || die "sed failed"
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake comparator.html scf-standard.html
+ distutils-r1_src_compile
+}
+
+src_install() {
+ emake ROOT="${D}" install
+ distutils-r1_src_install
+ docinto html
+ dodoc *.html
+}