summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-25 12:09:06 +0100
committerPacho Ramos <pacho@gentoo.org>2015-10-25 12:09:15 +0100
commit5f8ae790e0077f24e129df45b6a833ace70e6bcb (patch)
tree797adba193eb32c719589e9f20581be4dd182dd5 /dev-util/codeblocks/codeblocks-13.12-r1.ebuild
parentnet-firewall/firehol: x86 stable wrt bug #562504 (diff)
downloadgentoo-5f8ae790e0077f24e129df45b6a833ace70e6bcb.tar.gz
gentoo-5f8ae790e0077f24e129df45b6a833ace70e6bcb.tar.bz2
gentoo-5f8ae790e0077f24e129df45b6a833ace70e6bcb.zip
dev-util/codeblocks: Support wxGTK:3.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-util/codeblocks/codeblocks-13.12-r1.ebuild')
-rw-r--r--dev-util/codeblocks/codeblocks-13.12-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-13.12-r1.ebuild b/dev-util/codeblocks/codeblocks-13.12-r1.ebuild
new file mode 100644
index 000000000000..fa0a728898c8
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-13.12-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+WX_GTK_VER="3.0"
+
+inherit eutils wxwidgets
+
+DESCRIPTION="The open source, cross platform, free C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+SRC_URI="mirror://sourceforge/codeblocks/${P/-/_}-1.tar.gz"
+
+IUSE="contrib debug pch static-libs"
+
+RDEPEND="app-arch/zip
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ contrib? (
+ app-text/hunspell
+ dev-libs/boost:=
+ dev-libs/libgamin
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ need-wxwidgets unicode
+ econf \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable debug) \
+ $(use_enable pch) \
+ $(use_enable static-libs static) \
+ $(use_with contrib contrib-plugins all)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}