summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-19 14:07:51 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-19 14:08:49 +0100
commit00aa8c86613ba316ca16b3b353362a1a15c8a338 (patch)
tree42eb4d0ef37590e94baadb669ac6da6b03ab76c5 /dev-util/cmake/files
parentapp-emulation/docker-compose: Version bump to 1.19.0 (diff)
downloadgentoo-00aa8c86613ba316ca16b3b353362a1a15c8a338.tar.gz
gentoo-00aa8c86613ba316ca16b3b353362a1a15c8a338.tar.bz2
gentoo-00aa8c86613ba316ca16b3b353362a1a15c8a338.zip
dev-util/cmake: Bump to version 3.11.0_rc1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/cmake/files')
-rw-r--r--dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch b/dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch
new file mode 100644
index 000000000000..3a4c4352c6ff
--- /dev/null
+++ b/dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch
@@ -0,0 +1,21 @@
+--- cmake-3.11.0-rc1/Source/CMakeLists.txt
++++ cmake-3.11.0-rc1/Source/CMakeLists.txt
+@@ -765,6 +765,7 @@
+ ${CMAKE_LIBUV_LIBRARIES}
+ ${CMAKE_LIBRHASH_LIBRARIES}
+ ${CMake_KWIML_LIBRARIES}
++ pthread
+ )
+
+ if(CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR MATCHES "sparc")
+--- cmake-3.11.0-rc1/Tests/CMakeLib/CMakeLists.txt
++++ cmake-3.11.0-rc1/Tests/CMakeLib/CMakeLists.txt
+@@ -30,7 +30,7 @@
+
+ create_test_sourcelist(CMakeLib_TEST_SRCS CMakeLibTests.cxx ${CMakeLib_TESTS})
+ add_executable(CMakeLibTests ${CMakeLib_TEST_SRCS})
+-target_link_libraries(CMakeLibTests CMakeLib)
++target_link_libraries(CMakeLibTests CMakeLib pthread)
+
+ set_property(TARGET CMakeLibTests PROPERTY C_CLANG_TIDY "")
+ set_property(TARGET CMakeLibTests PROPERTY CXX_CLANG_TIDY "")