summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-23 10:34:50 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-23 10:44:52 +0100
commit47874192181d6b679aadc5d4be77429597e4c0d3 (patch)
tree1dd75d969c7f3816105714eeffd81b80ef0f59e5 /dev-util/catkin
parentdev-python/empy: Add pypy3 support (diff)
downloadgentoo-47874192181d6b679aadc5d4be77429597e4c0d3.tar.gz
gentoo-47874192181d6b679aadc5d4be77429597e4c0d3.tar.bz2
gentoo-47874192181d6b679aadc5d4be77429597e4c0d3.zip
dev-util/catkin: Add pypy3 support
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-util/catkin')
-rw-r--r--dev-util/catkin/catkin-0.7.6.ebuild2
-rw-r--r--dev-util/catkin/catkin-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/catkin/catkin-0.7.6.ebuild b/dev-util/catkin/catkin-0.7.6.ebuild
index 2bce0e1b502d..883e9a8828a2 100644
--- a/dev-util/catkin/catkin-0.7.6.ebuild
+++ b/dev-util/catkin/catkin-0.7.6.ebuild
@@ -10,7 +10,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ros/catkin"
fi
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
inherit ${SCM} cmake-utils python-r1 python-utils-r1
diff --git a/dev-util/catkin/catkin-9999.ebuild b/dev-util/catkin/catkin-9999.ebuild
index 2bce0e1b502d..883e9a8828a2 100644
--- a/dev-util/catkin/catkin-9999.ebuild
+++ b/dev-util/catkin/catkin-9999.ebuild
@@ -10,7 +10,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ros/catkin"
fi
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
inherit ${SCM} cmake-utils python-r1 python-utils-r1