summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-01-07 09:15:05 +0100
committerHans de Graaff <graaff@gentoo.org>2024-01-07 09:26:43 +0100
commit2d0f38b9b20d12f43b058bb907ec59733c2c8b4c (patch)
tree9a2876c95e05d33185024c49ea704be8fd3c1df5 /dev-ruby
parentdev-ruby/parser: add 3.3.0.1 (diff)
downloadgentoo-2d0f38b9b20d12f43b058bb907ec59733c2c8b4c.tar.gz
gentoo-2d0f38b9b20d12f43b058bb907ec59733c2c8b4c.tar.bz2
gentoo-2d0f38b9b20d12f43b058bb907ec59733c2c8b4c.zip
dev-ruby/rdiscount: add 2.2.7.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rdiscount/Manifest1
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.2.7.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/rdiscount/Manifest b/dev-ruby/rdiscount/Manifest
index a1ca297bfba7..5db221ea2c40 100644
--- a/dev-ruby/rdiscount/Manifest
+++ b/dev-ruby/rdiscount/Manifest
@@ -1 +1,2 @@
DIST rdiscount-2.2.7.1.gem 74240 BLAKE2B 06779a601c8d13b90f5d9fb1c38712431671eab1cb2ef012dee284ddb6da254a0c788f16295438913d68f3641db2ec48c7cea3bade4f36fdc55b7a6049119fd4 SHA512 e67bbbb7f19ef14a729642e2059f0920b65a3f254507204955ab6d34529ade643ee7adecc3db2c61ca5462d266f88ea336bd228401e3cd0fad98e2e7763dd8d3
+DIST rdiscount-2.2.7.3.gem 75776 BLAKE2B 6dc3110d0acf1adf86450e520e43e9d6602ca8980e85d5d0122f2e49026e6b6a32eca72a44631fa1fa03e6c649b21941a820cb07a1d8cc30d3bde3d3fdc74c5e SHA512 525791f2be10e118f556676a1645d2805ba6ad920e4f4c8761362c5aa09cf1f773f0216f7b6c2e1f78acbc1de1ac85c6088cc85729af70a28f537fdff3434786
diff --git a/dev-ruby/rdiscount/rdiscount-2.2.7.3.ebuild b/dev-ruby/rdiscount/rdiscount-2.2.7.3.ebuild
new file mode 100644
index 000000000000..1e2af68e91bb
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.2.7.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/davidfstr/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+
+ # Remove obsolete -rubygems argument, bug 775377
+ sed -i -e '/-rubygems/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}