summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/warden
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/warden')
-rw-r--r--dev-ruby/warden/Manifest1
-rw-r--r--dev-ruby/warden/metadata.xml8
-rw-r--r--dev-ruby/warden/warden-1.2.3.ebuild22
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/warden/Manifest b/dev-ruby/warden/Manifest
new file mode 100644
index 000000000000..fa3f00724782
--- /dev/null
+++ b/dev-ruby/warden/Manifest
@@ -0,0 +1 @@
+DIST warden-1.2.3.gem 30720 SHA256 97769e5b5d230fec4f77e91b1116b28fdd27428f4acab68dc5ed025af9d37f7a SHA512 c789710578239f9fdd4d7ebcd646bf7f1c22f2183d83fd95bbeb896c70eb2704b91ef64bfdd2624159e06c97baa2ab03ab12fc2ffbe04ce27fa6e829cf37d193 WHIRLPOOL c90aa134926698ca0ecae730bb04b2dcfb4f6ce29c690b929adf37a5fa59e6ea8aba692fbd5a102233eb24d995481d525cb94dc4acba0e489060dd4b5b801e91
diff --git a/dev-ruby/warden/metadata.xml b/dev-ruby/warden/metadata.xml
new file mode 100644
index 000000000000..9ae6416801c5
--- /dev/null
+++ b/dev-ruby/warden/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">hassox/warden</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/warden/warden-1.2.3.ebuild b/dev-ruby/warden/warden-1.2.3.ebuild
new file mode 100644
index 000000000000..a2bbd61562f5
--- /dev/null
+++ b/dev-ruby/warden/warden-1.2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.textile History.rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="General Rack Authentication Framework"
+HOMEPAGE="https://github.com/hassox/warden"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack"