summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-02 09:37:57 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-02 09:42:35 +0200
commit37406152b94e01ab4d9411f5b7f25e73f42fedda (patch)
tree1da47b2b41ff162cd089cc156a137b7d09c1c86d /dev-ruby/tzinfo/tzinfo-1.2.7.ebuild
parentsys-fs/multipath-tools: add json-c-0.14 support (diff)
downloadgentoo-37406152b94e01ab4d9411f5b7f25e73f42fedda.tar.gz
gentoo-37406152b94e01ab4d9411f5b7f25e73f42fedda.tar.bz2
gentoo-37406152b94e01ab4d9411f5b7f25e73f42fedda.zip
dev-ruby/tzinfo: add 1.2.7
Fix dependencies compared to 1.2.6. thread_safe is still required for this version. This drops the ~sparc keyword. Closes: https://bugs.gentoo.org/720290 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tzinfo/tzinfo-1.2.7.ebuild')
-rw-r--r--dev-ruby/tzinfo/tzinfo-1.2.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/tzinfo-1.2.7.ebuild b/dev-ruby/tzinfo/tzinfo-1.2.7.ebuild
new file mode 100644
index 000000000000..e9f6fb1018ac
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-1.2.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="test_zoneinfo"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="https://tzinfo.github.io/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/timezone-data"
+DEPEND="test? ( sys-libs/timezone-data )"
+
+ruby_add_rdepend ">=dev-ruby/thread_safe-0.1:0"
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Avoid taint tests that throw SecurityErrors on newer ruby versions.
+ sed -i -e '/_info_tainted/askip"SecurityError"' test/tc_ruby_data_source.rb || die
+}