summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-13 09:47:56 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-13 09:48:52 +0200
commitaa0907bf6811e7b00808513168a3f2b0e96eca97 (patch)
tree634eed831e6a946dd7f11c634b9a345535046bfb /dev-ruby/sprockets
parentdev-ruby/sprockets: add 4.1.1 (diff)
downloadgentoo-aa0907bf6811e7b00808513168a3f2b0e96eca97.tar.gz
gentoo-aa0907bf6811e7b00808513168a3f2b0e96eca97.tar.bz2
gentoo-aa0907bf6811e7b00808513168a3f2b0e96eca97.zip
dev-ruby/sprockets: drop 3.7.2, 3.7.2-r1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/sprockets')
-rw-r--r--dev-ruby/sprockets/sprockets-3.7.2-r1.ebuild61
-rw-r--r--dev-ruby/sprockets/sprockets-3.7.2.ebuild59
2 files changed, 0 insertions, 120 deletions
diff --git a/dev-ruby/sprockets/sprockets-3.7.2-r1.ebuild b/dev-ruby/sprockets/sprockets-3.7.2-r1.ebuild
deleted file mode 100644
index 0b2f62510c15..000000000000
--- a/dev-ruby/sprockets/sprockets-3.7.2-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="sprockets.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Ruby library for compiling and serving web assets"
-HOMEPAGE="https://github.com/rails/sprockets"
-SRC_URI="https://github.com/rails/sprockets/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-IUSE=""
-
-ruby_add_rdepend "
- dev-ruby/concurrent-ruby:1
- >=dev-ruby/rack-1:* <dev-ruby/rack-3:*"
-
-ruby_add_bdepend "test? (
- dev-ruby/json
- dev-ruby/rack-test
- =dev-ruby/coffee-script-2*
- =dev-ruby/execjs-2*
- =dev-ruby/sass-3* >=dev-ruby/sass-3.1
- dev-ruby/uglifier
- )"
-
-all_ruby_prepare() {
- # Avoid tests for template types that we currently don't package:
- # eco and ejs.
- sed -i -e '/eco templates/,/end/ s:^:#:' \
- -e '/ejs templates/,/end/ s:^:#:' test/test_environment.rb || die
- sed -i -e '/.ejs/ s:^:#:' test/test_asset.rb || die
- rm -f test/test_require.rb test/test_{closure,eco,ejs,yui}_{compressor,processor}.rb || die
- sed -i -e "/bundler/d" Rakefile || die
-}
-
-each_ruby_prepare() {
- sed -i -e "s:ruby:${RUBY}:" test/test_sprocketize.rb || die
-}
-
-each_ruby_test() {
- # Make sure we have completely separate copies. Hardlinks won't work
- # for this test suite.
- cp -R test test-new || die
- rm -rf test || die
- mv test-new test || die
-
- each_fakegem_test
-}
diff --git a/dev-ruby/sprockets/sprockets-3.7.2.ebuild b/dev-ruby/sprockets/sprockets-3.7.2.ebuild
deleted file mode 100644
index 842fe75b2a81..000000000000
--- a/dev-ruby/sprockets/sprockets-3.7.2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="sprockets.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Ruby library for compiling and serving web assets"
-HOMEPAGE="https://github.com/rails/sprockets"
-SRC_URI="https://github.com/rails/sprockets/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-IUSE=""
-
-ruby_add_rdepend "
- dev-ruby/concurrent-ruby:1
- >=dev-ruby/rack-1:* <dev-ruby/rack-3:*"
-
-ruby_add_bdepend "test? (
- dev-ruby/json
- dev-ruby/rack-test
- =dev-ruby/coffee-script-2*
- =dev-ruby/execjs-2*
- =dev-ruby/sass-3* >=dev-ruby/sass-3.1
- dev-ruby/uglifier
- )"
-
-all_ruby_prepare() {
- # Avoid tests for template types that we currently don't package:
- # eco and ejs.
- sed -i -e '/eco templates/,/end/ s:^:#:' \
- -e '/ejs templates/,/end/ s:^:#:' test/test_environment.rb || die
- sed -i -e '/.ejs/ s:^:#:' test/test_asset.rb || die
- rm -f test/test_require.rb test/test_{closure,eco,ejs,yui}_{compressor,processor}.rb || die
- sed -i -e "/bundler/d" Rakefile || die
-}
-
-each_ruby_prepare() {
- sed -i -e "s:ruby:${RUBY}:" test/test_sprocketize.rb || die
-}
-
-each_ruby_test() {
- # Make sure we have completely separate copies. Hardlinks won't work
- # for this test suite.
- cp -R test test-new || die
- rm -rf test || die
- mv test-new test || die
-
- each_fakegem_test
-}