summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-03-05 08:36:21 +0100
committerHans de Graaff <graaff@gentoo.org>2017-03-05 08:36:21 +0100
commita533fb566cf3cf9344ec2e31a10dee7ea37a2ede (patch)
treec541baa53fe0582cb7c0031dfae365b49c8d1847 /dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild
parentdev-ruby/uglifier: add 3.1.3 (diff)
downloadgentoo-a533fb566cf3cf9344ec2e31a10dee7ea37a2ede.tar.gz
gentoo-a533fb566cf3cf9344ec2e31a10dee7ea37a2ede.tar.bz2
gentoo-a533fb566cf3cf9344ec2e31a10dee7ea37a2ede.zip
dev-ruby/ruby-termios: Do not install bogus binstubs, bug 611688
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild')
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild b/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..bdc574354d6c
--- /dev/null
+++ b/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md termios.rd"
+
+# There are no tests in the gem, and the upstream tests only work
+# with a normal TTY, bug 340575.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby interface to termios"
+HOMEPAGE="http://arika.org/ruby/termios"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~x86-macos"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext V=1
+ cp ext/termios$(get_modname) lib/ || die
+}