summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-10-21 09:19:02 +0200
committerHans de Graaff <graaff@gentoo.org>2017-10-21 09:19:02 +0200
commit2fbd6a5a668dacd644954ea6b2b60f5bb5b59ca3 (patch)
treeac0516f9db4eafab951e49db7c6277259d16d0e0 /dev-ruby/rack/rack-1.6.5.ebuild
parentdev-ruby/coderay: cleanup (diff)
downloadgentoo-2fbd6a5a668dacd644954ea6b2b60f5bb5b59ca3.tar.gz
gentoo-2fbd6a5a668dacd644954ea6b2b60f5bb5b59ca3.tar.bz2
gentoo-2fbd6a5a668dacd644954ea6b2b60f5bb5b59ca3.zip
dev-ruby/rack: cleanup
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/rack/rack-1.6.5.ebuild')
-rw-r--r--dev-ruby/rack/rack-1.6.5.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/rack/rack-1.6.5.ebuild b/dev-ruby/rack/rack-1.6.5.ebuild
deleted file mode 100644
index af79f5844328..000000000000
--- a/dev-ruby/rack/rack-1.6.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="HISTORY.md KNOWN-ISSUES README.rdoc SPEC"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eutils versionator
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="https://rack.github.com/"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch ${PN}-1.6-rewindable-ruby23.patch )
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all.
-ruby_add_bdepend "test? ( dev-ruby/bacon )"
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.4.5-r1:1.4 !<dev-ruby/rack-1.5.2-r4:1.5"
-
-all_ruby_prepare() {
- # The build system tries to generate the ChangeLog from git. Create
- # an empty file to avoid a needless dependency on git.
- touch ChangeLog || die
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S bacon -Ilib -w -a \
- -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
- || die "test failed for ${RUBY}"
-}