summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-18 06:19:22 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-18 06:22:06 +0200
commite2194a6b13efcded9f354df3a8b4d2a4d13c8ff9 (patch)
treecdcec19186318ea36ac5f7e789813ccdbfe37b04 /dev-ruby/pkg-config/pkg-config-1.5.2.ebuild
parentdev-ruby/gruff: add 0.22.0 (diff)
downloadgentoo-e2194a6b13efcded9f354df3a8b4d2a4d13c8ff9.tar.gz
gentoo-e2194a6b13efcded9f354df3a8b4d2a4d13c8ff9.tar.bz2
gentoo-e2194a6b13efcded9f354df3a8b4d2a4d13c8ff9.zip
dev-ruby/pkg-config: add 1.5.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.5.2.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.5.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild b/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild
new file mode 100644
index 000000000000..d553cc41ba97
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/ruby-gnome/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ sed -e '/test_cflags/aomit "Fragile on Gentoo"' -i test/test-pkg-config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test-pkg-config.rb || die
+}