summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-12-05 19:30:33 +0100
committerHans de Graaff <graaff@gentoo.org>2022-12-05 19:35:50 +0100
commit583084622f3a29feb436bea767414b0be8ecd1e0 (patch)
tree8a48207db784ba2ce2bf51eee7e78f2cf5fd63a0 /dev-ruby/http
parentdev-ruby/i18n: drop 1.8.9 (diff)
downloadgentoo-583084622f3a29feb436bea767414b0be8ecd1e0.tar.gz
gentoo-583084622f3a29feb436bea767414b0be8ecd1e0.tar.bz2
gentoo-583084622f3a29feb436bea767414b0be8ecd1e0.zip
dev-ruby/http: drop 4.4.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/http')
-rw-r--r--dev-ruby/http/http-4.4.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/http/http-4.4.1.ebuild b/dev-ruby/http/http-4.4.1.ebuild
deleted file mode 100644
index 333cc3f6edbe..000000000000
--- a/dev-ruby/http/http-4.4.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An easy-to-use client library for making requests from Ruby"
-HOMEPAGE="https://github.com/tarcieri/http"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.3:0
- >=dev-ruby/http-cookie-1.0:0
- >=dev-ruby/http-form_data-2.2:2
- =dev-ruby/http-parser-1.2*"
-
-ruby_add_bdepend "
- test? ( dev-ruby/certificate_authority dev-ruby/rspec-its )"
-
-all_ruby_prepare() {
- sed -i -e '/simplecov/,/end/ s:^:#:' \
- -e '1irequire "cgi"' spec/spec_helper.rb || die
-
- # Avoid specs that require network access
- sed -i -e '/.persistent/,/^ end/ s:^:#:' \
- spec/lib/http_spec.rb || die
- sed -i -e '/with non-ASCII URLs/,/^ end/ s:^:#:' \
- spec/lib/http/client_spec.rb || die
-
- # Avoid spec that may fail with a running web server
- sed -i -e '/unifies socket errors into HTTP::ConnectionError/,/^ end/ s:^:#:' spec/lib/http_spec.rb || die
-
- # Fix spec for production release
- sed -i -e '/User-Agent:/ s/.dev//' spec/lib/http/features/logging_spec.rb || die
-
- # Avoid specs also failing upstream due to some certificate issue
- sed -i -e '/context "ssl"/,/^ end/ s:^:#:' spec/lib/http_spec.rb || die
- sed -i -e '/describe "working with SSL"/,/^ end/ s:^:#:' spec/lib/http/client_spec.rb || die
-}