summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/fakefs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/fakefs')
-rw-r--r--dev-ruby/fakefs/Manifest3
-rw-r--r--dev-ruby/fakefs/fakefs-0.6.0-r1.ebuild40
-rw-r--r--dev-ruby/fakefs/fakefs-0.6.0.ebuild40
-rw-r--r--dev-ruby/fakefs/fakefs-0.6.5.ebuild40
-rw-r--r--dev-ruby/fakefs/fakefs-0.6.7.ebuild44
-rw-r--r--dev-ruby/fakefs/metadata.xml8
6 files changed, 175 insertions, 0 deletions
diff --git a/dev-ruby/fakefs/Manifest b/dev-ruby/fakefs/Manifest
new file mode 100644
index 000000000000..9c382f456989
--- /dev/null
+++ b/dev-ruby/fakefs/Manifest
@@ -0,0 +1,3 @@
+DIST fakefs-0.6.0.gem 41984 SHA256 43a668e9a436654d66eff7e896793800b4b8d87c3ecd5a6a84e23fb52580150e SHA512 8c0eac75103e1917551e2f5e74a5324d5a606e7692a8e4c49c9b97e2b5005bd381073a5780a8e6d1fb661a1bb4a67e56c29ce98cd2e2e62cce22602c30e4225f WHIRLPOOL c1a520c9cf3913e727ef570367d238e2ec88eb8d41789d1d33e9227a5a5dd9c62f4a462374066e1e5b5c5ac8bb0f738e6513b4d4182c20969178a82f90aa2739
+DIST fakefs-0.6.5.gem 44032 SHA256 4c3c5378c839bd8f8e94dab767b417c74273cefda703bf338358d8e964bbf9ed SHA512 eef1500627eac9d2df312a74783ee43f3bcc8aaa83824cfb2ccf11bb6d21cc0e6d95d72a4aab78eaa15edbe9a856146ec3ef97408569d5eac56fc4bba2a12f56 WHIRLPOOL 09c03ae8500343ac771f019a21b19494d94e3fd1f114d78c9ba037d214e40a2927b083652a24d044190bb9cb81ded0ac2b1e1ea1dab953fbce462c541184b3da
+DIST fakefs-0.6.7.gem 44544 SHA256 2fd9f56aecac9de55db0b4111f4f53d6ebbe00e68dd1cc089cc4c2d8589eb9a1 SHA512 1fe50b7692a153dfc2d48cb0fb4eb545a52c04362154d72a8b887f7d8f9fb5973abc13c685eba0f9cd4dbdf5a783ab8de2bd978747050b72b4f248c1a0d271c2 WHIRLPOOL cf7a3a96f1efcd70b233fa129f0c5782b6b19bb3039960d2de981c9dc889c60956d313e8b17a21fab31a23013cce2b3fc2fd8f33f2603323c2e315aa85c18370
diff --git a/dev-ruby/fakefs/fakefs-0.6.0-r1.ebuild b/dev-ruby/fakefs/fakefs-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..873c9607dd44
--- /dev/null
+++ b/dev-ruby/fakefs/fakefs-0.6.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# requires sdoc
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTORS README.markdown"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fake filesystem. Use it in your tests"
+HOMEPAGE="http://github.com/defunkt/fakefs"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec:2
+ >=dev-ruby/test-unit-2.5.1-r1
+ )"
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ ruby-ng_rspec
+ ruby-ng_testrb-2 -Ilib:test test/**/*_test.rb
+}
diff --git a/dev-ruby/fakefs/fakefs-0.6.0.ebuild b/dev-ruby/fakefs/fakefs-0.6.0.ebuild
new file mode 100644
index 000000000000..58ae0575801f
--- /dev/null
+++ b/dev-ruby/fakefs/fakefs-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# requires sdoc
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTORS README.markdown"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fake filesystem. Use it in your tests"
+HOMEPAGE="http://github.com/defunkt/fakefs"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec:2
+ >=dev-ruby/test-unit-2.5.1-r1
+ )"
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ ruby-ng_rspec
+ ruby-ng_testrb-2 -Ilib:test test/**/*_test.rb
+}
diff --git a/dev-ruby/fakefs/fakefs-0.6.5.ebuild b/dev-ruby/fakefs/fakefs-0.6.5.ebuild
new file mode 100644
index 000000000000..8857c77c7c12
--- /dev/null
+++ b/dev-ruby/fakefs/fakefs-0.6.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# requires sdoc
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTORS README.markdown"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fake filesystem. Use it in your tests"
+HOMEPAGE="http://github.com/defunkt/fakefs"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/rspec-3.1:3
+ >=dev-ruby/test-unit-2.5.1-r1
+ )"
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec
+ ruby-ng_testrb-2 -Ilib:test test/**/*_test.rb
+}
diff --git a/dev-ruby/fakefs/fakefs-0.6.7.ebuild b/dev-ruby/fakefs/fakefs-0.6.7.ebuild
new file mode 100644
index 000000000000..05ddc3f89b58
--- /dev/null
+++ b/dev-ruby/fakefs/fakefs-0.6.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# requires sdoc
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTORS README.markdown"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fake filesystem. Use it in your tests"
+HOMEPAGE="https://github.com/defunkt/fakefs"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/rspec-3.1:3
+ >=dev-ruby/minitest-5.5
+ )"
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+
+ # Avoid unneeded minitest-rg dependency.
+ sed -i -e '1igem "minitest", "~>5.5"' \
+ -e '/minitest\/rg/ s:^:#:' test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/fakefs/metadata.xml b/dev-ruby/fakefs/metadata.xml
new file mode 100644
index 000000000000..7b7164296d36
--- /dev/null
+++ b/dev-ruby/fakefs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">defunkt/fakefs</remote-id>
+ </upstream>
+</pkgmetadata>