summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-06 07:23:17 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-06 07:33:58 +0200
commit43ae71f805b947acf2dceb93e5494377136b36fe (patch)
tree158c53c0ea77d2782c6bafadf3ebd30c024621ea /dev-ruby/cgi
parentdev-ruby/web-console: add 4.2.1 (diff)
downloadgentoo-43ae71f805b947acf2dceb93e5494377136b36fe.tar.gz
gentoo-43ae71f805b947acf2dceb93e5494377136b36fe.tar.bz2
gentoo-43ae71f805b947acf2dceb93e5494377136b36fe.zip
dev-ruby/cgi: fix name in gemspec
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/cgi')
-rw-r--r--dev-ruby/cgi/cgi-0.3.6-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/cgi/cgi-0.3.6-r1.ebuild b/dev-ruby/cgi/cgi-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..7408dc861613
--- /dev/null
+++ b/dev-ruby/cgi/cgi-0.3.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/cgi/escape/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="cgi.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Support for the Common Gateway Interface protocol"
+HOMEPAGE="https://github.com/ruby/cgi"
+SRC_URI="https://github.com/ruby/cgi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -e "/spec.version/ s/= version/= '${PV}'/" \
+ -e "/spec.name/ s/= name/= '${PN}'/" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -rtest/lib/helper -e "Dir['test/**/test_*.rb'].each { require _1 }" || die
+}