summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-23 15:54:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-23 15:54:32 +0200
commita31fbc56824b5b8c3cedf1be833608ec0cd6b2f5 (patch)
treeecef89c1d1789964b2ef68e7c6f8ec3dafc85237 /dev-ros/rospack/files
parentmedia-libs/vamp-plugin-sdk: Bump to 2.7.1 (diff)
downloadgentoo-a31fbc56824b5b8c3cedf1be833608ec0cd6b2f5.tar.gz
gentoo-a31fbc56824b5b8c3cedf1be833608ec0cd6b2f5.tar.bz2
gentoo-a31fbc56824b5b8c3cedf1be833608ec0cd6b2f5.zip
dev-ros/rospack: Drop python-single-r1 hack, build libraries linking to different python implementations and install a compat symlink for now.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rospack/files')
-rw-r--r--dev-ros/rospack/files/multipy.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/rospack/files/multipy.patch b/dev-ros/rospack/files/multipy.patch
new file mode 100644
index 000000000000..8350cc0a8da2
--- /dev/null
+++ b/dev-ros/rospack/files/multipy.patch
@@ -0,0 +1,40 @@
+Install separate libraries linking to different python implementations.
+
+Index: rospack-2.4.1/CMakeLists.txt
+===================================================================
+--- rospack-2.4.1.orig/CMakeLists.txt
++++ rospack-2.4.1/CMakeLists.txt
+@@ -23,28 +23,28 @@ endif()
+
+ include_directories(include ${TinyXML2_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
+
+-add_library(rospack
++add_library(rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}
+ src/rospack.cpp
+ ${backcompat_source}
+ src/rospack_cmdline.cpp
+ src/utils.cpp
+ )
+-target_link_libraries(rospack ${TinyXML2_LIBRARIES} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
++target_link_libraries(rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} ${TinyXML2_LIBRARIES} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
+
+ add_executable(rospackexe src/rospack_main.cpp)
+ # Set the name, and make it a "global" executable
+ set_target_properties(rospackexe PROPERTIES
+ OUTPUT_NAME rospack
+ RUNTIME_OUTPUT_DIRECTORY ${CATKIN_DEVEL_PREFIX}/bin)
+-target_link_libraries(rospackexe rospack ${Boost_LIBRARIES})
++target_link_libraries(rospackexe rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} ${Boost_LIBRARIES})
+ add_executable(rosstackexe src/rosstack_main.cpp)
+-target_link_libraries(rosstackexe rospack ${Boost_LIBRARIES})
++target_link_libraries(rosstackexe rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} ${Boost_LIBRARIES})
+ # Set the name, and make it a "global" executable
+ set_target_properties(rosstackexe PROPERTIES
+ OUTPUT_NAME rosstack
+ RUNTIME_OUTPUT_DIRECTORY ${CATKIN_DEVEL_PREFIX}/bin)
+
+-install(TARGETS rospack rospackexe rosstackexe
++install(TARGETS rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} rospackexe rosstackexe
+ ARCHIVE DESTINATION ${CATKIN_PACKAGE_LIB_DESTINATION}
+ LIBRARY DESTINATION ${CATKIN_PACKAGE_LIB_DESTINATION}
+ RUNTIME DESTINATION ${CATKIN_GLOBAL_BIN_DESTINATION})