summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-24 14:29:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-24 15:44:32 +0200
commit39f268a994fc7d9db2ba81713a3fb7f52d70953c (patch)
treeb97a03ad93c21228a6309073f7f976bb21d88cd1 /dev-ros/rosbag_storage
parentdev-ros/rosgraph: fix tests (diff)
downloadgentoo-39f268a994fc7d9db2ba81713a3fb7f52d70953c.tar.gz
gentoo-39f268a994fc7d9db2ba81713a3fb7f52d70953c.tar.bz2
gentoo-39f268a994fc7d9db2ba81713a3fb7f52d70953c.zip
dev-ros/rosbag_storage: fix tests
Closes: https://bugs.gentoo.org/738586 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosbag_storage')
-rw-r--r--dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild6
-rw-r--r--dev-ros/rosbag_storage/rosbag_storage-9999.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild b/dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild
index ecde5f7cc189..b4ede837ca4e 100644
--- a/dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild
+++ b/dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild
@@ -39,3 +39,9 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
)
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild b/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
index ecde5f7cc189..b4ede837ca4e 100644
--- a/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
+++ b/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
@@ -39,3 +39,9 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
)
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}