summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-15 08:35:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-15 08:35:25 +0200
commitd62749ff74c14d998163742b83e445148e2272ae (patch)
tree7e3405a90f92b6abb590e7963a774ac1ff14cd29 /dev-ros/cv_bridge/cv_bridge-1.12.8.ebuild
parentdev-python/catkin_pkg: bump to 0.4.2 and fix tests (diff)
downloadgentoo-d62749ff74c14d998163742b83e445148e2272ae.tar.gz
gentoo-d62749ff74c14d998163742b83e445148e2272ae.tar.bz2
gentoo-d62749ff74c14d998163742b83e445148e2272ae.zip
dev-ros/cv_bridge: Bump to 1.12.8.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/cv_bridge/cv_bridge-1.12.8.ebuild')
-rw-r--r--dev-ros/cv_bridge/cv_bridge-1.12.8.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/cv_bridge/cv_bridge-1.12.8.ebuild b/dev-ros/cv_bridge/cv_bridge-1.12.8.ebuild
new file mode 100644
index 000000000000..781df6ff0219
--- /dev/null
+++ b/dev-ros/cv_bridge/cv_bridge-1.12.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Converts between ROS Image messages and OpenCV images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosconsole
+ >=media-libs/opencv-3:=[contrib(+)]
+ dev-libs/boost:=[threads,python,${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"