summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-24 07:37:58 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-25 18:08:06 -0400
commit4d83f8f0859e6060cb191e2b7b66259937369f20 (patch)
tree376c086ebf5f64c3c25994d1db4486a1d63241db /dev-qt/qtbase
parentgames-engines/fheroes2: drop 1.0.12 (diff)
downloadgentoo-4d83f8f0859e6060cb191e2b7b66259937369f20.tar.gz
gentoo-4d83f8f0859e6060cb191e2b7b66259937369f20.tar.bz2
gentoo-4d83f8f0859e6060cb191e2b7b66259937369f20.zip
dev-qt/qtbase: disable relocatable builds
And skip 3 tests that newly fail to find some resources (or at least, if qtbase is not already installed). Not worth keeping enabled over these. Meant to wait for 6.6.3 to merge this to lessen rebuilds, but looks like it may(?) be delayed again. Bug: https://bugs.gentoo.org/927691 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtbase')
-rw-r--r--dev-qt/qtbase/qtbase-6.6.2-r1.ebuild (renamed from dev-qt/qtbase/qtbase-6.6.2.ebuild)5
-rw-r--r--dev-qt/qtbase/qtbase-6.6.9999.ebuild5
-rw-r--r--dev-qt/qtbase/qtbase-6.7.0_rc2-r1.ebuild (renamed from dev-qt/qtbase/qtbase-6.7.0_rc2.ebuild)5
-rw-r--r--dev-qt/qtbase/qtbase-6.7.9999.ebuild5
-rw-r--r--dev-qt/qtbase/qtbase-6.9999.ebuild5
5 files changed, 25 insertions, 0 deletions
diff --git a/dev-qt/qtbase/qtbase-6.6.2.ebuild b/dev-qt/qtbase/qtbase-6.6.2-r1.ebuild
index b91ae109dba2..f842fee2eae4 100644
--- a/dev-qt/qtbase/qtbase-6.6.2.ebuild
+++ b/dev-qt/qtbase/qtbase-6.6.2-r1.ebuild
@@ -168,6 +168,7 @@ src_configure() {
-DINSTALL_SYSCONFDIR="${QT6_SYSCONFDIR}"
-DINSTALL_TRANSLATIONSDIR="${QT6_TRANSLATIONDIR}"
+ -DQT_FEATURE_relocatable=OFF #927691
$(qt_feature ssl openssl)
$(qt_feature ssl openssl_linked)
$(qt_feature udev libudev)
@@ -274,6 +275,10 @@ src_test() {
# broken with out-of-source + if qtbase is not already installed
tst_moc
tst_qmake
+ # similarly broken when relocatable=OFF (bug #927691)
+ tst_qapplication
+ tst_qt_cmake_create
+ tst_uic
# needs x11/opengl, we *could* run these but tend to be flaky
# when opengl rendering is involved (even if software-only)
tst_qopengl{,config,widget,window}
diff --git a/dev-qt/qtbase/qtbase-6.6.9999.ebuild b/dev-qt/qtbase/qtbase-6.6.9999.ebuild
index 76bd87ab7e87..1adebe3c5958 100644
--- a/dev-qt/qtbase/qtbase-6.6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.6.9999.ebuild
@@ -169,6 +169,7 @@ src_configure() {
-DQT_UNITY_BUILD=ON # ~30% faster build, affects other dev-qt/* too
+ -DQT_FEATURE_relocatable=OFF #927691
$(qt_feature ssl openssl)
$(qt_feature ssl openssl_linked)
$(qt_feature udev libudev)
@@ -275,6 +276,10 @@ src_test() {
# broken with out-of-source + if qtbase is not already installed
tst_moc
tst_qmake
+ # similarly broken when relocatable=OFF (bug #927691)
+ tst_qapplication
+ tst_qt_cmake_create
+ tst_uic
# needs x11/opengl, we *could* run these but tend to be flaky
# when opengl rendering is involved (even if software-only)
tst_qopengl{,config,widget,window}
diff --git a/dev-qt/qtbase/qtbase-6.7.0_rc2.ebuild b/dev-qt/qtbase/qtbase-6.7.0_rc2-r1.ebuild
index 5efe5d84f51e..87d5fb955203 100644
--- a/dev-qt/qtbase/qtbase-6.7.0_rc2.ebuild
+++ b/dev-qt/qtbase/qtbase-6.7.0_rc2-r1.ebuild
@@ -177,6 +177,7 @@ src_configure() {
-DQT_UNITY_BUILD=ON # ~30% faster build, affects other dev-qt/* too
+ -DQT_FEATURE_relocatable=OFF #927691
$(qt_feature ssl openssl)
$(qt_feature ssl openssl_linked)
$(qt_feature udev libudev)
@@ -285,6 +286,10 @@ src_test() {
# broken with out-of-source + if qtbase is not already installed
tst_moc
tst_qmake
+ # similarly broken when relocatable=OFF (bug #927691)
+ tst_qapplication
+ tst_qt_cmake_create
+ tst_uic
# needs x11/opengl, we *could* run these but tend to be flaky
# when opengl rendering is involved (even if software-only)
tst_qopengl{,config,widget,window}
diff --git a/dev-qt/qtbase/qtbase-6.7.9999.ebuild b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
index 5efe5d84f51e..87d5fb955203 100644
--- a/dev-qt/qtbase/qtbase-6.7.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
@@ -177,6 +177,7 @@ src_configure() {
-DQT_UNITY_BUILD=ON # ~30% faster build, affects other dev-qt/* too
+ -DQT_FEATURE_relocatable=OFF #927691
$(qt_feature ssl openssl)
$(qt_feature ssl openssl_linked)
$(qt_feature udev libudev)
@@ -285,6 +286,10 @@ src_test() {
# broken with out-of-source + if qtbase is not already installed
tst_moc
tst_qmake
+ # similarly broken when relocatable=OFF (bug #927691)
+ tst_qapplication
+ tst_qt_cmake_create
+ tst_uic
# needs x11/opengl, we *could* run these but tend to be flaky
# when opengl rendering is involved (even if software-only)
tst_qopengl{,config,widget,window}
diff --git a/dev-qt/qtbase/qtbase-6.9999.ebuild b/dev-qt/qtbase/qtbase-6.9999.ebuild
index 5efe5d84f51e..87d5fb955203 100644
--- a/dev-qt/qtbase/qtbase-6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.9999.ebuild
@@ -177,6 +177,7 @@ src_configure() {
-DQT_UNITY_BUILD=ON # ~30% faster build, affects other dev-qt/* too
+ -DQT_FEATURE_relocatable=OFF #927691
$(qt_feature ssl openssl)
$(qt_feature ssl openssl_linked)
$(qt_feature udev libudev)
@@ -285,6 +286,10 @@ src_test() {
# broken with out-of-source + if qtbase is not already installed
tst_moc
tst_qmake
+ # similarly broken when relocatable=OFF (bug #927691)
+ tst_qapplication
+ tst_qt_cmake_create
+ tst_uic
# needs x11/opengl, we *could* run these but tend to be flaky
# when opengl rendering is involved (even if software-only)
tst_qopengl{,config,widget,window}