summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-21 03:46:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-21 04:31:01 +0200
commitd42c2cea3f5f42376bd12ff2a6993fbb63bf9031 (patch)
tree6cd26fdc7fb479bb63cf96a0c6409ca0f0c372c6 /dev-python
parentdev-python/sphinx: Bump to 7.4.7 (diff)
downloadgentoo-d42c2cea3f5f42376bd12ff2a6993fbb63bf9031.tar.gz
gentoo-d42c2cea3f5f42376bd12ff2a6993fbb63bf9031.tar.bz2
gentoo-d42c2cea3f5f42376bd12ff2a6993fbb63bf9031.zip
dev-python/Nuitka: Bump to 2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-2.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index ffd8813c1dfd..43e8b1ed1e9e 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,3 +1,4 @@
DIST Nuitka-2.3.10.tar.gz 3702002 BLAKE2B 6aa0a890d1db4f245686c87152855ff23c71726d34025bcd41fe9fb639ff78002396f7400aafbee59249b1a06238fd5384bdfb48e5b961580020cd7f02ce4e4d SHA512 757c332afe2099fdc4708ea83776657d669811d2215360bcdbd4b6d2765fabca81a533d8bf7122c570318d3363cb2a3b1f511f4b6fa28abbc6a3d046fb7ff23d
DIST Nuitka-2.3.11.tar.gz 3701661 BLAKE2B c318bf839ad334c49eb145ecd7074e9c36f982af13a10cc8226ce0aeddea5b6cd69be9a3279a1e0da9f83934e3cc0f6d02d1c5f469839d6e6be05d056c8e2a68 SHA512 4165a922e79027cc71b7ecf175c5e85a071e6661613d9dc95ba553d4d167b979726094c025af513e7e62eb0553f206b31408d233ffd74f1256d163c31d127e16
DIST Nuitka-2.3.9.tar.gz 3701334 BLAKE2B 8e86496330ddcbab61a875c173bcaa8acee74b4942efe7e0947c2e2536605bd8ba7eab59533766a0d308c446a577456ed398c703d71b58e9d53bba8fcc484c00 SHA512 6039580292d3cbb3adb2ad504c996f83beaa583336cbdcfae92c8310ffaabd8b9510451c2ceffb6a4c26f82e8e9c112468670eb8b5cdaae96ed152f3f9337272
+DIST Nuitka-2.4.tar.gz 3718936 BLAKE2B 385a2bb2bbaa971277d7812f53d5a141a9643b0886e46e90fc3f5f8e3cb991801414ce6215a075ffe7998a99a65d534d2af16f9c4adc6c48fd8dee428461563a SHA512 c622434f48bea3d651c4720f8d22f23ec1ba680f9b58c66772a229ca1dc671a6c702d34503d4f16588008300e8e7e32a73dd51b56da1de8edbb33fde62be6053
diff --git a/dev-python/Nuitka/Nuitka-2.4.ebuild b/dev-python/Nuitka/Nuitka-2.4.ebuild
new file mode 100644
index 000000000000..274aff9ae3b5
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}