summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-17 07:11:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-17 07:58:48 +0200
commit9a674d113deaa44249688fc1ab08e7a09c094449 (patch)
treebdd4cf49001dd6e88a6bd91a755174162308ce6d /dev-python
parentdev-db/citus: Bump to 11.0.2 (diff)
downloadgentoo-9a674d113deaa44249688fc1ab08e7a09c094449.tar.gz
gentoo-9a674d113deaa44249688fc1ab08e7a09c094449.tar.bz2
gentoo-9a674d113deaa44249688fc1ab08e7a09c094449.zip
dev-python/warlock: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/warlock/Manifest1
-rw-r--r--dev-python/warlock/warlock-2.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/warlock/Manifest b/dev-python/warlock/Manifest
index 3bdb3e841574..754d1b55c988 100644
--- a/dev-python/warlock/Manifest
+++ b/dev-python/warlock/Manifest
@@ -1 +1,2 @@
DIST warlock-1.3.3.gh.tar.gz 11147 BLAKE2B 1281348076500315c5aa105691b8e5a50ccf2ba79335fb8581a0b89bfc96bb3076a797c4ebe011f6c347667a0971bbbdd2b1bf413d0692ae5977216c524cbee0 SHA512 8a9135a17ccc0d0939ad98eee16100ec68b911d672b3af549f7629edcd6e08129f9e4ab707082593274fc896bc405ab6d6ba9e4bf6fc40b8522ec99327c983ec
+DIST warlock-2.0.0.gh.tar.gz 19823 BLAKE2B 538f0b8797277ab067c22a5c43a0fc236fe9a5e1117a00d93fc390100f48503415e7db73bbf4639f7ffa08933b026aafc009eba3a2719f42727b78a4f4ac862d SHA512 56ef0aaf8d7bb706e79832d606eaa2c927dd43880a09d339388cae0d629815b2c31bf53ae6005d02fb4d91708ac889586e635b2cdd068f6498c97f6b2276b1b5
diff --git a/dev-python/warlock/warlock-2.0.0.ebuild b/dev-python/warlock/warlock-2.0.0.ebuild
new file mode 100644
index 000000000000..90b6658386cb
--- /dev/null
+++ b/dev-python/warlock/warlock-2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python object model built on JSON schema and JSON patch"
+HOMEPAGE="
+ https://github.com/bcwaldon/warlock/
+ https://pypi.org/project/warlock/
+"
+SRC_URI="
+ https://github.com/bcwaldon/warlock/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/jsonpatch-1[${PYTHON_USEDEP}]
+ <dev-python/jsonpatch-2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-0.7[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' pytest.ini || die
+ distutils-r1_src_prepare
+}