summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-18 18:17:04 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-18 18:23:23 +0200
commita6e7afbaec56eb08f43682f6381c16b9f1e7198f (patch)
treee7ab662f7c94374a87a9b0ab99722f48c0ababde /dev-python
parentdev-libs/efl: clean old (diff)
downloadgentoo-a6e7afbaec56eb08f43682f6381c16b9f1e7198f.tar.gz
gentoo-a6e7afbaec56eb08f43682f6381c16b9f1e7198f.tar.bz2
gentoo-a6e7afbaec56eb08f43682f6381c16b9f1e7198f.zip
dev-python/twisted: Remove +x from files/trial
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--[-rwxr-xr-x]dev-python/twisted/files/trial0
-rw-r--r--dev-python/twisted/twisted-16.6.0-r3.ebuild3
-rw-r--r--dev-python/twisted/twisted-17.1.0-r2.ebuild3
-rw-r--r--dev-python/twisted/twisted-17.9.0.ebuild3
-rw-r--r--dev-python/twisted/twisted-18.4.0.ebuild3
-rw-r--r--dev-python/twisted/twisted-18.7.0.ebuild3
6 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/twisted/files/trial b/dev-python/twisted/files/trial
index 8da58861abf6..8da58861abf6 100755..100644
--- a/dev-python/twisted/files/trial
+++ b/dev-python/twisted/files/trial
diff --git a/dev-python/twisted/twisted-16.6.0-r3.ebuild b/dev-python/twisted/twisted-16.6.0-r3.ebuild
index cc2d554f4023..61c95aa34aad 100644
--- a/dev-python/twisted/twisted-16.6.0-r3.ebuild
+++ b/dev-python/twisted/twisted-16.6.0-r3.ebuild
@@ -112,7 +112,8 @@ python_test() {
# workaround for the eclass not installing the entry points
# in the test environment. copy the old 16.3.2 start script
# to run the tests with
- cp "${FILESDIR}"/trial "${TEST_DIR}"
+ cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+ chmod +x "${TEST_DIR}"/trial || die
pushd "${TEST_DIR}" > /dev/null || die
diff --git a/dev-python/twisted/twisted-17.1.0-r2.ebuild b/dev-python/twisted/twisted-17.1.0-r2.ebuild
index 7b72031402e4..2c5297195b28 100644
--- a/dev-python/twisted/twisted-17.1.0-r2.ebuild
+++ b/dev-python/twisted/twisted-17.1.0-r2.ebuild
@@ -113,7 +113,8 @@ python_test() {
# workaround for the eclass not installing the entry points
# in the test environment. copy the old 16.3.2 start script
# to run the tests with
- cp "${FILESDIR}"/trial "${TEST_DIR}"
+ cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+ chmod +x "${TEST_DIR}"/trial || die
pushd "${TEST_DIR}" > /dev/null || die
diff --git a/dev-python/twisted/twisted-17.9.0.ebuild b/dev-python/twisted/twisted-17.9.0.ebuild
index d9ab3a98e0b0..2af9dc590099 100644
--- a/dev-python/twisted/twisted-17.9.0.ebuild
+++ b/dev-python/twisted/twisted-17.9.0.ebuild
@@ -120,7 +120,8 @@ python_test() {
# workaround for the eclass not installing the entry points
# in the test environment. copy the old 16.3.2 start script
# to run the tests with
- cp "${FILESDIR}"/trial "${TEST_DIR}"
+ cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+ chmod +x "${TEST_DIR}"/trial || die
pushd "${TEST_DIR}" > /dev/null || die
diff --git a/dev-python/twisted/twisted-18.4.0.ebuild b/dev-python/twisted/twisted-18.4.0.ebuild
index 05bc6ecafa7b..62428e4db226 100644
--- a/dev-python/twisted/twisted-18.4.0.ebuild
+++ b/dev-python/twisted/twisted-18.4.0.ebuild
@@ -119,7 +119,8 @@ python_test() {
# workaround for the eclass not installing the entry points
# in the test environment. copy the old 16.3.2 start script
# to run the tests with
- cp "${FILESDIR}"/trial "${TEST_DIR}"
+ cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+ chmod +x "${TEST_DIR}"/trial || die
pushd "${TEST_DIR}" > /dev/null || die
diff --git a/dev-python/twisted/twisted-18.7.0.ebuild b/dev-python/twisted/twisted-18.7.0.ebuild
index a3d79b03733a..9b927dd62be5 100644
--- a/dev-python/twisted/twisted-18.7.0.ebuild
+++ b/dev-python/twisted/twisted-18.7.0.ebuild
@@ -121,7 +121,8 @@ python_test() {
# workaround for the eclass not installing the entry points
# in the test environment. copy the old 16.3.2 start script
# to run the tests with
- cp "${FILESDIR}"/trial "${TEST_DIR}"
+ cp "${FILESDIR}"/trial "${TEST_DIR}" || die
+ chmod +x "${TEST_DIR}"/trial || die
pushd "${TEST_DIR}" > /dev/null || die