summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-08 08:01:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-08 08:07:39 +0200
commit812ea49f24bc108f87cab87eb004bbc6f22b8e16 (patch)
tree20f6eb330e763214e1f62089009455806532f1d2 /dev-python
parentdev-python/django-auth-ldap: Remove old (diff)
downloadgentoo-812ea49f24bc108f87cab87eb004bbc6f22b8e16.tar.gz
gentoo-812ea49f24bc108f87cab87eb004bbc6f22b8e16.tar.bz2
gentoo-812ea49f24bc108f87cab87eb004bbc6f22b8e16.zip
dev-python/django-filter: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-filter/Manifest1
-rw-r--r--dev-python/django-filter/django-filter-22.1.ebuild46
-rw-r--r--dev-python/django-filter/files/django-filter-22.1-test-skipIf.patch22
3 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/django-filter/Manifest b/dev-python/django-filter/Manifest
index cb7783fa0db4..a85859cefd12 100644
--- a/dev-python/django-filter/Manifest
+++ b/dev-python/django-filter/Manifest
@@ -1,2 +1 @@
-DIST django-filter-22.1.gh.tar.gz 132450 BLAKE2B 9ef9a4ee15ebd3d461803b4dbbdf9a415e7004ee6b9eaaa75c87f9b3993461e6e294621182478ba0ad06595937c9b98fe89d16e9c48e34ced7dd525f40dc926f SHA512 9db2e684815a69c8b28b512c994ad1845c7a3e53da5dc762e5833c1ee4d90c5e513aa5cb3e59d9033c509b44fe9c27ce4fe798842aec50e040c06d33cb18ec0a
DIST django-filter-23.1.gh.tar.gz 135407 BLAKE2B a23b7c6ae4692bd991aee4c0dfc4beb699ffbaec4e831dd3d13cb7b76f6acf4ba015c73bc7c9be21f6d95dfe17691f43baeda1f04b7e8757ced315c80d111d72 SHA512 c8437c3806e9d0e05bbbb938d225abe05da33103c729ccdb97dd47b7482178530a3fed5efba22458440530bd71cc9a171bae8fa81c2a67a50e5c6f34f2c300a2
diff --git a/dev-python/django-filter/django-filter-22.1.ebuild b/dev-python/django-filter/django-filter-22.1.ebuild
deleted file mode 100644
index 96a3f517f036..000000000000
--- a/dev-python/django-filter/django-filter-22.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Django app allowing declarative dynamic QuerySet filtering from URL parameters"
-HOMEPAGE="
- https://github.com/carltongibson/django-filter/
- https://pypi.org/project/django-filter/
-"
-SRC_URI="
- https://github.com/carltongibson/django-filter/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/django-3.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/coreapi[${PYTHON_USEDEP}]
- dev-python/djangorestframework[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-test-skipIf.patch
-)
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.settings
- "${EPYTHON}" -m django test -v 2 || die
-}
diff --git a/dev-python/django-filter/files/django-filter-22.1-test-skipIf.patch b/dev-python/django-filter/files/django-filter-22.1-test-skipIf.patch
deleted file mode 100644
index 883700899175..000000000000
--- a/dev-python/django-filter/files/django-filter-22.1-test-skipIf.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/tests/rest_framework/test_filterset.py b/tests/rest_framework/test_filterset.py
-index d1cb51a..b6f89cf 100644
---- a/tests/rest_framework/test_filterset.py
-+++ b/tests/rest_framework/test_filterset.py
-@@ -4,7 +4,7 @@ from django.conf import settings
- from django.test import TestCase
- from django.test.utils import override_settings
-
--from django_filters.compat import is_crispy
-+from django_filters.compat import crispy_forms
- from django_filters.rest_framework import FilterSet, filters
- from django_filters.widgets import BooleanWidget
-
-@@ -37,7 +37,7 @@ class FilterSetFilterForFieldTests(TestCase):
- self.assertEqual(result.extra["widget"], BooleanWidget)
-
-
--@skipIf(is_crispy(), "django_crispy_forms must be installed")
-+@skipIf(crispy_forms is None, "django_crispy_forms must be installed")
- @override_settings(INSTALLED_APPS=settings.INSTALLED_APPS + ("crispy_forms",))
- class CrispyFormsCompatTests(TestCase):
- def test_crispy_helper(self):