summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-31 11:23:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-31 11:25:32 +0200
commit6913545c667e99155639f28865733abf9ab80589 (patch)
tree945fc5d7d7b85fd8b77514603a6e508264723b4d /dev-python
parentnet-analyzer/gvm-libs: add 22.7.0 (diff)
downloadgentoo-6913545c667e99155639f28865733abf9ab80589.tar.gz
gentoo-6913545c667e99155639f28865733abf9ab80589.tar.bz2
gentoo-6913545c667e99155639f28865733abf9ab80589.zip
dev-python/sphinx-prompt: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-prompt/Manifest1
-rw-r--r--dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinx-prompt/Manifest b/dev-python/sphinx-prompt/Manifest
index 40e999b561fe..d68d73969f3c 100644
--- a/dev-python/sphinx-prompt/Manifest
+++ b/dev-python/sphinx-prompt/Manifest
@@ -1 +1,2 @@
DIST sphinx-prompt-1.6.0.gh.tar.gz 38245 BLAKE2B da2ac8564e14a10d5b51ea5ebd2e5578e7c2795ea7f3c5d3f054c621090e4bf634b9a1f578f4c010bbeaa61cc0d18f1a48ce6c0d9a316e34504ada1b4fb61d7b SHA512 a896dad9d333fde843ab90f331be40c533fa32f75f68dfc012a6296d96661e726647250642e1cc4c54125d9acb237add640008671a657a5e47a885450831c21e
+DIST sphinx-prompt-1.7.0.gh.tar.gz 38317 BLAKE2B b042b7821d16ff63d259b73de476f96cafea32345dc98d24a9abb97dd46ecbd6947862ef727b830c27889f4b8a17c30c8dd86a4bddd38294a3a4bca00349bf87 SHA512 1b0df502c75ea4cac4e4a5b11c0aa762851b82c39892410c97f0ed45bdd74e5706a580a906d4ebb8c47700324c089c5114eba12cd4617aba37cfea8c338ac9d5
diff --git a/dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild b/dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild
new file mode 100644
index 000000000000..b8e7c5e14a20
--- /dev/null
+++ b/dev-python/sphinx-prompt/sphinx-prompt-1.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx directive to add unselectable prompt"
+HOMEPAGE="
+ https://github.com/sbrunner/sphinx-prompt/
+ https://pypi.org/project/sphinx-prompt/
+"
+SRC_URI="
+ https://github.com/sbrunner/sphinx-prompt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # upstream repeatedly fails to update version number
+ # also pins all dependencies to exact versions, sigh
+ sed -i \
+ -e "/^version =/s:[0-9.]\+:${PV}:" \
+ -e '/^\[tool\.poetry\.dependencies\]$/,$s:"[0-9.]\+:"*:' \
+ pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}