summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-08 14:29:40 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-08 15:04:51 +0100
commit4c34964e0c0c5a09dfe228d3b52d8e7050945fe3 (patch)
treee3b399e29604dcd3419d27806c5ac8d1316a68f8 /dev-python
parentdev-python/svglib: Bump to 1.5.1 (diff)
downloadgentoo-4c34964e0c0c5a09dfe228d3b52d8e7050945fe3.tar.gz
gentoo-4c34964e0c0c5a09dfe228d3b52d8e7050945fe3.tar.bz2
gentoo-4c34964e0c0c5a09dfe228d3b52d8e7050945fe3.zip
dev-python/django-tables2: Bump to 2.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-tables2/Manifest1
-rw-r--r--dev-python/django-tables2/django-tables2-2.5.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/django-tables2/Manifest b/dev-python/django-tables2/Manifest
index d778af29dc41..3b9ff1ed5c97 100644
--- a/dev-python/django-tables2/Manifest
+++ b/dev-python/django-tables2/Manifest
@@ -1,3 +1,4 @@
DIST django-tables2-2.3.4.tar.gz 77706 BLAKE2B 54e0903747ab29dab26049868f8cfd412d23fe3f36eaf292bebc90ee1c307f08d04af1eed469423e3699db227110fc0347a8034acb3b3b46971d37b3aebb84a1 SHA512 d10144b79850847d2787e4a97f450eb3709a419a5dcd330667e3746c16f3be7472c6c26dbf7d765356130b79b8c915c46fd3201c83e66806753f1bb95911895f
DIST django-tables2-2.4.1.gh.tar.gz 429723 BLAKE2B 80361d419279f548c089c4da990a45c6b43576746ec2762928af907415f3ea331a89f7e0ec7b792d27e15ed409b25f3ee26b3794cdb16255835f0d74faee068c SHA512 e2431f86e049b9dee1100d48727ea2003e431a3ad5bf8e8a4b773d53dc4d5e90ec310a7f07ce7532e044903d760aacda37b3512770f6e0db6527842d1cbdd6d9
DIST django-tables2-2.5.0.gh.tar.gz 430376 BLAKE2B 592a488fea869c2b0630c8d3ad72182636206a2b394355a2702c2dbeac43a67f9175a9f7756349c3d7877d2887af0e32816e2a4c9ba5234f04e9828fe38ffe29 SHA512 b0a31860205c5e68a520d1fdbfe16e094701dbcf1cf8c46d62c32b8194c121271832f08ca0fdb4c05cb52c1fde5ef66e323d3f772e2562da4f48188128cfa8a0
+DIST django-tables2-2.5.1.gh.tar.gz 430778 BLAKE2B 7811880ec49a514b74252d32fbc59d800aaa34fb2bf4af5675d1c4555c7a52f9eb3ca67d8d940697146c07de1e42006c6d3880a53b31a386bd088aa6939b056f SHA512 baf955b255dcbcf09250cfdbb2dc1fb51f3f9142ad29bf4ca8888344d1bcbe9f23a59f1509cad7e847d82bb6d410a494ed9eae1d4d4ca633e7f0351e4a98839d
diff --git a/dev-python/django-tables2/django-tables2-2.5.1.ebuild b/dev-python/django-tables2/django-tables2-2.5.1.ebuild
new file mode 100644
index 000000000000..148dde53f147
--- /dev/null
+++ b/dev-python/django-tables2/django-tables2-2.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Table/data-grid framework for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-tables2/
+ https://github.com/jieter/django-tables2/
+"
+SRC_URI="
+ https://github.com/jieter/django-tables2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/django-filter[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # these tests require tablib
+ rm tests/test_export.py tests/test_templatetags.py || die
+ # these tests require fudge
+ rm tests/test_config.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" manage.py test -v 2 tests || die
+}