summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-23 06:58:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-23 07:17:33 +0100
commit2311156b81e925355bab4634e539d2af422bb117 (patch)
tree9d24385ca7522e2e88dcd0f4c2056c6425bba8dd /dev-python
parentmedia-libs/libshumate: fix tests w/ newer json-glib (diff)
downloadgentoo-2311156b81e925355bab4634e539d2af422bb117.tar.gz
gentoo-2311156b81e925355bab4634e539d2af422bb117.tar.bz2
gentoo-2311156b81e925355bab4634e539d2af422bb117.zip
dev-python/jaraco-path: Bump to 3.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-path/Manifest1
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.7.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jaraco-path/Manifest b/dev-python/jaraco-path/Manifest
index e9f6aa17b032..56e2946d8aee 100644
--- a/dev-python/jaraco-path/Manifest
+++ b/dev-python/jaraco-path/Manifest
@@ -1 +1,2 @@
DIST jaraco_path-3.7.1.tar.gz 11771 BLAKE2B 25ba1ff90514984be0885c0507ebe554372f4fa32aadda1a1bda8bde1781d60e81726fa899e863bf0d34ec49a79c57052b2b5b4035cd2655cdbb513df54da626 SHA512 aa002c649b4d0d4dbfc7bd3fe25b4ef71ca3c92d200029c282453002c75d3c642630b4ba4bfd0355a6311c72407fc874b3a092daa94ed99824f129119dd464d0
+DIST jaraco_path-3.7.2.tar.gz 12360 BLAKE2B 0e0a70e0af49db7e4ce9b54825beb057214277dd57e62c48f0ff2388ff2d489fe82d8773f7544464a64f0e83a9b95c8f794a91de2e6000360f0ebfee2693b03d SHA512 7869308504601368ef94c414e4d0c19d6115dccbb0d50b5287a15d3d31948c93ccfd01db71c95d534f670fdf61b2e2c00deb873ee1e81b7f6bc1bdf0d3a1f9a9
diff --git a/dev-python/jaraco-path/jaraco-path-3.7.2.ebuild b/dev-python/jaraco-path/jaraco-path-3.7.2.ebuild
new file mode 100644
index 000000000000..97281217d16a
--- /dev/null
+++ b/dev-python/jaraco-path/jaraco-path-3.7.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Miscellaneous path functions"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.path/
+ https://pypi.org/project/jaraco.path/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests
+}