summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-13 06:01:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-13 06:01:55 +0200
commit0c8d7152f1e13fb843ad83da16c545dabe79209f (patch)
tree6f01a428a58ccadc12bd12eaa0de916ffbdba1b7 /dev-python
parentdev-python/pydantic: Bump to 2.7.4 (diff)
downloadgentoo-0c8d7152f1e13fb843ad83da16c545dabe79209f.tar.gz
gentoo-0c8d7152f1e13fb843ad83da16c545dabe79209f.tar.bz2
gentoo-0c8d7152f1e13fb843ad83da16c545dabe79209f.zip
dev-python/wurlitzer: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wurlitzer/Manifest1
-rw-r--r--dev-python/wurlitzer/wurlitzer-3.1.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/wurlitzer/Manifest b/dev-python/wurlitzer/Manifest
index 5d1cdeec7d10..366d8f34127e 100644
--- a/dev-python/wurlitzer/Manifest
+++ b/dev-python/wurlitzer/Manifest
@@ -1 +1,2 @@
DIST wurlitzer-3.1.0.tar.gz 11571 BLAKE2B 2b7be0f34d1f7b5e15cce51ad749d31e3cd28b9693812aba2c9bcd2b38efc4cf2302abfabf74d11c9929a4951194fc284d05de8c068414626604497e98eb859f SHA512 c285f4169191bca9fb3e4fca884c35d630bbe0b9b9db0952a96888e97f2d27cd82d9defba7fbd2efba14ee2214235743eca1d9e8e79074b8bed2f1af066c0412
+DIST wurlitzer-3.1.1.tar.gz 11867 BLAKE2B 840e3340180acd646b51e976153e423f2265d3346c0617ae57b0c73d3463e7b455315e1265368a277298827190679bd46c799e09dc656f8899ffbf4c7e75265e SHA512 69e57343ae60bcab560861dabbf2a8e60210f163ac902c787473b1c46d998895760aeeac90e45f1d7ed799e7468f6d1dd543b1dd85ac0c826f9186015a1890a8
diff --git a/dev-python/wurlitzer/wurlitzer-3.1.1.ebuild b/dev-python/wurlitzer/wurlitzer-3.1.1.ebuild
new file mode 100644
index 000000000000..78272e742f37
--- /dev/null
+++ b/dev-python/wurlitzer/wurlitzer-3.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Capture C-level stdout/stderr in Python"
+HOMEPAGE="
+ https://github.com/minrk/wurlitzer/
+ https://pypi.org/project/wurlitzer/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}