summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-11-13 13:45:01 -0800
committerZac Medico <zmedico@gentoo.org>2016-11-13 13:46:26 -0800
commitfbec5fbdba3df94db37a5fcfcd0a1751e568e571 (patch)
treeb8fd030b2efc1aa8225e0a8309b1652c72873e4e /dev-python/yarl
parentwww-client/chromium: fix null pointer deref in V8 with gcc-6 (diff)
downloadgentoo-fbec5fbdba3df94db37a5fcfcd0a1751e568e571.tar.gz
gentoo-fbec5fbdba3df94db37a5fcfcd0a1751e568e571.tar.bz2
gentoo-fbec5fbdba3df94db37a5fcfcd0a1751e568e571.zip
dev-python/yarl: disable pytest-runner requirement (bug 599672)
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/yarl-0.7.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/yarl/yarl-0.7.0.ebuild b/dev-python/yarl/yarl-0.7.0.ebuild
index 260259aa619a..07320e7adbc5 100644
--- a/dev-python/yarl/yarl-0.7.0.ebuild
+++ b/dev-python/yarl/yarl-0.7.0.ebuild
@@ -19,6 +19,12 @@ IUSE="test"
DEPEND="test? ( dev-python/pytest-runner[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"
+src_prepare() {
+ # pytest-runner is not really required unless tests are enabled
+ sed -e "s:'pytest-runner',\\?::" -i setup.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
esetup.py test || die
}