summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-08-09 13:38:20 +0200
committerSam James <sam@gentoo.org>2022-08-23 06:24:52 +0100
commitcec62a9a65361ddca152837e838325ae641a2f1d (patch)
treecf25708836da3e5baa29d21b988d4cc95a5dee5b /dev-python/yara-python/yara-python-4.2.3.ebuild
parentapp-forensics/yara: drop 4.2.0-r1, 4.2.1 (diff)
downloadgentoo-cec62a9a65361ddca152837e838325ae641a2f1d.tar.gz
gentoo-cec62a9a65361ddca152837e838325ae641a2f1d.tar.bz2
gentoo-cec62a9a65361ddca152837e838325ae641a2f1d.zip
dev-python/yara-python: add 4.2.3
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/26794 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/yara-python/yara-python-4.2.3.ebuild')
-rw-r--r--dev-python/yara-python/yara-python-4.2.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/yara-python/yara-python-4.2.3.ebuild b/dev-python/yara-python/yara-python-4.2.3.ebuild
new file mode 100644
index 000000000000..e4fa379a2709
--- /dev/null
+++ b/dev-python/yara-python/yara-python-4.2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface for a malware identification and classification tool"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ =app-forensics/yara-$(ver_cut 1-2)*"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ cat >> setup.cfg <<-EOF
+ [build_ext]
+ dynamic-linking = True
+ EOF
+}
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}