summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-15 08:17:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-15 10:23:31 +0200
commit89345efc2ce87748d7e3962078c5117f9e841532 (patch)
tree0cf7317c598683b019f7ec41f09a9e0f8fe8b0a3 /dev-python/xmlschema
parentdev-python/loky: Bump to 3.4.0 (diff)
downloadgentoo-89345efc2ce87748d7e3962078c5117f9e841532.tar.gz
gentoo-89345efc2ce87748d7e3962078c5117f9e841532.tar.bz2
gentoo-89345efc2ce87748d7e3962078c5117f9e841532.zip
dev-python/xmlschema: Bump to 2.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-2.2.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 29a3b7772f0a..dcbd979eabed 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-2.2.2.tar.gz 492479 BLAKE2B 1d06841587172d8e67959e0096ac48c0ea3e63c24fa64d2ce9098a7031800a67aa73da9c7b4dcd1cde6ff8999bbc6c675dd157f962461f12446855788d38638a SHA512 a1bbc30e6233192cd275079019cd902d363b23bc02404686713dc16c05bf3a817676db20b6e6e5e7d8d6b9c9e228be3b19e541d0d3a9946765643894fcedc00e
+DIST xmlschema-2.2.3.tar.gz 493444 BLAKE2B 64b8cbc27fe0378cc0a90e110f5c816a25f8b67b61b12363b200035cdc60ba1492923589a8b2b8d3c8a20ecaef85c6acb3c448a377d793efe87f7ad7a6a95bc3 SHA512 978f48d1d79cc8c4f3eab22fd2396da24abd42ea5d36439b72a7783d59e17863b647039a3a058513efd170e78c340705d5729dabd28aa8c26b0c4b2133a67222
diff --git a/dev-python/xmlschema/xmlschema-2.2.3.ebuild b/dev-python/xmlschema/xmlschema-2.2.3.ebuild
new file mode 100644
index 000000000000..c53430e64d4d
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-2.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/elementpath-5[${PYTHON_USEDEP}]
+ >=dev-python/elementpath-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v || die "Tests fail with ${EPYTHON}"
+}