summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 13:12:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-26 13:21:36 +0100
commit11e691ee9b5d9b8b56c1289163cefb7f1fcfa534 (patch)
treec1de85a2e09b58c3af33b0255a663203d9f40076 /dev-python/wheel
parentdev-python/graph-tool: drop 2.43 (diff)
downloadgentoo-11e691ee9b5d9b8b56c1289163cefb7f1fcfa534.tar.gz
gentoo-11e691ee9b5d9b8b56c1289163cefb7f1fcfa534.tar.bz2
gentoo-11e691ee9b5d9b8b56c1289163cefb7f1fcfa534.zip
dev-python/wheel: Use flit to ease bootstrap
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/wheel-0.37.1-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/wheel/wheel-0.37.1-r1.ebuild b/dev-python/wheel/wheel-0.37.1-r1.ebuild
new file mode 100644
index 000000000000..a271177181e7
--- /dev/null
+++ b/dev-python/wheel/wheel-0.37.1-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.org/project/wheel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed \
+ -e 's:--cov --cov-config=setup.cfg::g' \
+ -i setup.cfg || die
+
+ # unbundle packaging
+ rm -r src/wheel/vendored || die
+ sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ [[ -e pyproject.toml ]] &&
+ die "Upstream added pyproject.toml, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "wheel"
+ description = "A built-package format for Python"
+ dynamic = ["version"]
+
+ [project.scripts]
+ wheel = "wheel.cli:main"
+
+ [project.entry-points."distutils.commands"]
+ bdist_wheel = "wheel.bdist_wheel:bdist_wheel"
+ EOF
+}