summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-25 20:51:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-25 20:51:42 +0200
commit0d6aae0932544a1b8586b96a0310fe0c5c101c59 (patch)
tree7bb4fe1057f4546b7578f00e618bfd101ee7e9d1 /dev-python/websockify
parentdev-python/pytools: Remove old (diff)
downloadgentoo-0d6aae0932544a1b8586b96a0310fe0c5c101c59.tar.gz
gentoo-0d6aae0932544a1b8586b96a0310fe0c5c101c59.tar.bz2
gentoo-0d6aae0932544a1b8586b96a0310fe0c5c101c59.zip
dev-python/websockify: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockify')
-rw-r--r--dev-python/websockify/Manifest1
-rw-r--r--dev-python/websockify/files/websockify-0.10.0-fix-jwcrypto-1.3.patch114
-rw-r--r--dev-python/websockify/websockify-0.10.0-r2.ebuild48
3 files changed, 0 insertions, 163 deletions
diff --git a/dev-python/websockify/Manifest b/dev-python/websockify/Manifest
index 4234752f0452..e92af3c83f31 100644
--- a/dev-python/websockify/Manifest
+++ b/dev-python/websockify/Manifest
@@ -1,2 +1 @@
-DIST websockify-0.10.0.gh.tar.gz 53402 BLAKE2B e909dc316d6dd0ee03ee23b07ca2d78cc60994a8f361b3968759c382c704637357848e903fb12af002b5d5b2bec957f9a4c2b0ddb0e6d008ff9b4a462f3e8871 SHA512 262071f4858e5e3b6471c6f3731d8715c5c13fcc5f43738a330323958a8f0cbe7797847bdc676f1c6c34055c6f8afb949d005a5607d6b220b893910ff973ddc5
DIST websockify-0.11.0.gh.tar.gz 55126 BLAKE2B df49e8025ea0341b7f8d329a3b3dcddc08df3d0b42bbcb33d25726df8fee1f0a8791d552c9019a3ae514549619a0f3cc9c7861ff4f30017f27498f7465fd5d11 SHA512 cbae6abdee3c9ba6e78c2245fa7ebc4bd6aa96a534b8577da1ae9acd316dd146cece6ceb6f6cdca9c1ddcb3cbaff69e0fc3c3d6048b9374b0937abb91843bf72
diff --git a/dev-python/websockify/files/websockify-0.10.0-fix-jwcrypto-1.3.patch b/dev-python/websockify/files/websockify-0.10.0-fix-jwcrypto-1.3.patch
deleted file mode 100644
index 9da2cfe093dc..000000000000
--- a/dev-python/websockify/files/websockify-0.10.0-fix-jwcrypto-1.3.patch
+++ /dev/null
@@ -1,114 +0,0 @@
-From 0f175003480b666fba78a5eda8dbc1dee07917dd Mon Sep 17 00:00:00 2001
-From: Javier Cacheiro <javier.cacheiro.lopez@cesga.es>
-Date: Wed, 25 May 2022 12:40:29 +0200
-Subject: [PATCH] Support for jwcrypto>=1.3
-
----
- tests/test_token_plugins.py | 20 ++++++++++----------
- websockify/token_plugins.py | 4 ++--
- 2 files changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/tests/test_token_plugins.py b/tests/test_token_plugins.py
-index 00078c7..3e1fd19 100644
---- a/tests/test_token_plugins.py
-+++ b/tests/test_token_plugins.py
-@@ -4,7 +4,7 @@
-
- import unittest
- from unittest.mock import patch, mock_open, MagicMock
--from jwcrypto import jwt
-+from jwcrypto import jwt, jwk
-
- from websockify.token_plugins import ReadOnlyTokenFile, JWTTokenApi, TokenRedis
-
-@@ -56,7 +56,7 @@ class JWSTokenTestCase(unittest.TestCase):
- def test_asymmetric_jws_token_plugin(self):
- plugin = JWTTokenApi("./tests/fixtures/public.pem")
-
-- key = jwt.JWK()
-+ key = jwk.JWK()
- private_key = open("./tests/fixtures/private.pem", "rb").read()
- key.import_from_pem(private_key)
- jwt_token = jwt.JWT({"alg": "RS256"}, {'host': "remote_host", 'port': "remote_port"})
-@@ -71,7 +71,7 @@ def test_asymmetric_jws_token_plugin(self):
- def test_asymmetric_jws_token_plugin_with_illigal_key_exception(self):
- plugin = JWTTokenApi("wrong.pub")
-
-- key = jwt.JWK()
-+ key = jwk.JWK()
- private_key = open("./tests/fixtures/private.pem", "rb").read()
- key.import_from_pem(private_key)
- jwt_token = jwt.JWT({"alg": "RS256"}, {'host': "remote_host", 'port': "remote_port"})
-@@ -85,7 +85,7 @@ def test_asymmetric_jws_token_plugin_with_illigal_key_exception(self):
- def test_jwt_valid_time(self, mock_time):
- plugin = JWTTokenApi("./tests/fixtures/public.pem")
-
-- key = jwt.JWK()
-+ key = jwk.JWK()
- private_key = open("./tests/fixtures/private.pem", "rb").read()
- key.import_from_pem(private_key)
- jwt_token = jwt.JWT({"alg": "RS256"}, {'host': "remote_host", 'port': "remote_port", 'nbf': 100, 'exp': 200 })
-@@ -102,7 +102,7 @@ def test_jwt_valid_time(self, mock_time):
- def test_jwt_early_time(self, mock_time):
- plugin = JWTTokenApi("./tests/fixtures/public.pem")
-
-- key = jwt.JWK()
-+ key = jwk.JWK()
- private_key = open("./tests/fixtures/private.pem", "rb").read()
- key.import_from_pem(private_key)
- jwt_token = jwt.JWT({"alg": "RS256"}, {'host': "remote_host", 'port': "remote_port", 'nbf': 100, 'exp': 200 })
-@@ -117,7 +117,7 @@ def test_jwt_early_time(self, mock_time):
- def test_jwt_late_time(self, mock_time):
- plugin = JWTTokenApi("./tests/fixtures/public.pem")
-
-- key = jwt.JWK()
-+ key = jwk.JWK()
- private_key = open("./tests/fixtures/private.pem", "rb").read()
- key.import_from_pem(private_key)
- jwt_token = jwt.JWT({"alg": "RS256"}, {'host': "remote_host", 'port': "remote_port", 'nbf': 100, 'exp': 200 })
-@@ -132,7 +132,7 @@ def test_symmetric_jws_token_plugin(self):
- plugin = JWTTokenApi("./tests/fixtures/symmetric.key")
-
- secret = open("./tests/fixtures/symmetric.key").read()
-- key = jwt.JWK()
-+ key = jwk.JWK()
- key.import_key(kty="oct",k=secret)
- jwt_token = jwt.JWT({"alg": "HS256"}, {'host': "remote_host", 'port': "remote_port"})
- jwt_token.make_signed_token(key)
-@@ -147,7 +147,7 @@ def test_symmetric_jws_token_plugin_with_illigal_key_exception(self):
- plugin = JWTTokenApi("wrong_sauce")
-
- secret = open("./tests/fixtures/symmetric.key").read()
-- key = jwt.JWK()
-+ key = jwk.JWK()
- key.import_key(kty="oct",k=secret)
- jwt_token = jwt.JWT({"alg": "HS256"}, {'host': "remote_host", 'port': "remote_port"})
- jwt_token.make_signed_token(key)
-@@ -159,8 +159,8 @@ def test_symmetric_jws_token_plugin_with_illigal_key_exception(self):
- def test_asymmetric_jwe_token_plugin(self):
- plugin = JWTTokenApi("./tests/fixtures/private.pem")
-
-- private_key = jwt.JWK()
-- public_key = jwt.JWK()
-+ private_key = jwk.JWK()
-+ public_key = jwk.JWK()
- private_key_data = open("./tests/fixtures/private.pem", "rb").read()
- public_key_data = open("./tests/fixtures/public.pem", "rb").read()
- private_key.import_from_pem(private_key_data)
-diff --git a/websockify/token_plugins.py b/websockify/token_plugins.py
-index 4dc29de..19005d3 100644
---- a/websockify/token_plugins.py
-+++ b/websockify/token_plugins.py
-@@ -103,10 +103,10 @@ class JWTTokenApi(BasePlugin):
-
- def lookup(self, token):
- try:
-- from jwcrypto import jwt
-+ from jwcrypto import jwt, jwk
- import json
-
-- key = jwt.JWK()
-+ key = jwk.JWK()
-
- try:
- with open(self.source, 'rb') as key_file:
diff --git a/dev-python/websockify/websockify-0.10.0-r2.ebuild b/dev-python/websockify/websockify-0.10.0-r2.ebuild
deleted file mode 100644
index bb90baa958b8..000000000000
--- a/dev-python/websockify/websockify-0.10.0-r2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="WebSockets support for any application/server"
-HOMEPAGE="
- https://github.com/novnc/websockify/
- https://pypi.org/project/websockify/
-"
-SRC_URI="
- https://github.com/novnc/websockify/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/jwcrypto[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-jwcrypto-1.3.patch"
-)
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # TODO: incompatible with current jwcrypto? (not a regression)
- tests/test_token_plugins.py::JWSTokenTestCase::test_asymmetric_jwe_token_plugin
-)
-
-python_install_all() {
- doman docs/${PN}.1
- distutils-r1_python_install_all
-}