summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2017-12-17 10:24:30 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2017-12-17 17:22:54 +0000
commit17e2b60acb7049e925c1d65116dbb4edf16e820e (patch)
treeae371484a3803d1eabbf324799016b4bc2141e5c /dev-python/vobject/vobject-0.9.5.ebuild
parentnet-wireless/gr-doa: [QA] Remove empty <use/> block (diff)
downloadgentoo-17e2b60acb7049e925c1d65116dbb4edf16e820e.tar.gz
gentoo-17e2b60acb7049e925c1d65116dbb4edf16e820e.tar.bz2
gentoo-17e2b60acb7049e925c1d65116dbb4edf16e820e.zip
dev-python/vobject: add 0.9.5 ebuild
Cloned 0.9.3 ebuild with stable keywords dropped to unstable. This is required to add app-misc/khard into the tree, as khard is broken with vobject-0.9.3. Cc: python@gentoo.org Acked-by: Michał Górny <mgorny@gentoo.org> Acked-by: Mike Gilbert <floppym@gentoo.org> Bug: https://bugs.gentoo.org/601440 Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'dev-python/vobject/vobject-0.9.5.ebuild')
-rw-r--r--dev-python/vobject/vobject-0.9.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/vobject/vobject-0.9.5.ebuild b/dev-python/vobject/vobject-0.9.5.ebuild
new file mode 100644
index 000000000000..aaf93db14a72
--- /dev/null
+++ b/dev-python/vobject/vobject-0.9.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package for parsing and generating vCard and vCalendar files"
+HOMEPAGE="http://eventable.github.io/vobject/
+ https://pypi.python.org/pypi/vobject
+ https://github.com/eventable/vobject"
+SRC_URI="https://github.com/eventable/vobject/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools"[${PYTHON_USEDEP}]
+DEPEND="${RDEPEND}"
+
+DOCS=( ACKNOWLEDGEMENTS.txt README.md )
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Testing failed under ${EPYTHON}"
+}