summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-16 19:37:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-16 19:37:09 +0300
commit3b4eabc3858f40649f5245ebae097878804bb488 (patch)
tree7f39e0b3147f41113544f0b87485ef62dce8845b /dev-python/visitor
parentdev-python/verboselogs: enable py3.11 (diff)
downloadgentoo-3b4eabc3858f40649f5245ebae097878804bb488.tar.gz
gentoo-3b4eabc3858f40649f5245ebae097878804bb488.tar.bz2
gentoo-3b4eabc3858f40649f5245ebae097878804bb488.zip
dev-python/visitor: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/visitor')
-rw-r--r--dev-python/visitor/visitor-0.1.3-r2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/visitor/visitor-0.1.3-r2.ebuild b/dev-python/visitor/visitor-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..d1baf6a25481
--- /dev/null
+++ b/dev-python/visitor/visitor-0.1.3-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tiny pythonic visitor implementation"
+HOMEPAGE="https://github.com/mbr/visitor"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/visitor/pull/2
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest