summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-10-29 13:33:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-10-29 13:40:32 -0500
commit9f2e73347ce997e5d8f0d2ceef8c5fddb419842a (patch)
treef77ac87d17327b0311043c1729bec5d8831faada /dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild
parentdev-python/virtualenv-clone: support py36 as well (diff)
downloadgentoo-9f2e73347ce997e5d8f0d2ceef8c5fddb419842a.tar.gz
gentoo-9f2e73347ce997e5d8f0d2ceef8c5fddb419842a.tar.bz2
gentoo-9f2e73347ce997e5d8f0d2ceef8c5fddb419842a.zip
dev-python/virtualenvwrapper: 4.8.2 bup
Package-Manager: Portage-2.3.8, Repoman-2.3.4
Diffstat (limited to 'dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild')
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild
new file mode 100644
index 000000000000..3cf33e1ade92
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="
+ http://www.doughellmann.com/projects/virtualenvwrapper
+ https://pypi.python.org/pypi/virtualenvwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# testsuite doesn't work out of the box. Demand of a virtualenv outstrips setup by the eclass
+RESTRICT=test
+
+RDEPEND="
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+python_test() {
+ bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
+}