summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-17 07:40:59 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-17 07:56:27 +0200
commit31ca5f6a998f5e7641746958923e5e0561b60ff8 (patch)
tree031a5134364eb8d519fa10151fcead9841788360 /dev-python/virtualenv
parentdev-python/tqdm: Bump to 4.48.0 (diff)
downloadgentoo-31ca5f6a998f5e7641746958923e5e0561b60ff8.tar.gz
gentoo-31ca5f6a998f5e7641746958923e5e0561b60ff8.tar.bz2
gentoo-31ca5f6a998f5e7641746958923e5e0561b60ff8.zip
dev-python/virtualenv: Bump to 20.0.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest1
-rw-r--r--dev-python/virtualenv/virtualenv-20.0.27.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index b78e3181d6a7..b3b81c3a197c 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -3,3 +3,4 @@ DIST virtualenv-16.7.10.tar.gz 5116776 BLAKE2B 42f0a4b4330850b504f8febd991ef6ecd
DIST virtualenv-16.7.9.tar.gz 5116740 BLAKE2B 10b77c4d74d3b1be60d567caf60b48274893777313d7151350df1d8a7d86d7cbd299c6c04734cbad134512e2ea05f5bc694648b6e9307019ffd9b91f7d0cdaf5 SHA512 d7379941e299c44beba30eaab68d5f1a6650f767b24f95d5e8abd05c1529dca4c1423113a41ff42690bb2b2bd4fe05c3e47a8fed4f9df0972188f6c77034436b
DIST virtualenv-20.0.23.tar.gz 8038565 BLAKE2B e11a7e36c33848fc9c8ad12fed369e6804c11a89e11cb66ff105b4e4e5758dcab15809932f88d9ddbc229d1bb862d29dead9ff2e4da655603e627887a1a2cd1d SHA512 01a56564ac09abca25cd163e7b425d8dbf1f57d6771b57e1f5fe4182f86197009e7ebdcb6f4a8640c8b8f0cdfcfdcd843f7be33848c66b0b5877cc7a8fe6ee0e
DIST virtualenv-20.0.26.tar.gz 8264088 BLAKE2B 0d5bfbae10fa7de73ec3766863415a5a8f6680b168ef4ef25984b91a9291645189b987bfc63b96897b6f421fd692b4a388eee7a36995b0b65fe52d3019813da4 SHA512 d81fa8f25b7752fbb76494cea62f76d5f40e1397853ef71c1eb8078ffe8748fb365f275cc34ef04f64a001e3300a6f26f872542f68c047bee1eeb74cd49180a7
+DIST virtualenv-20.0.27.tar.gz 8265353 BLAKE2B 31e0a5fa11d988b5340b130615dc5095a61321393fdc4f72fd88e70d88bc7922c2f8f289b995fb623d2fe900a7da8f012433d4a7bb2ecd7ab53810865e05ea2b SHA512 812a17d1461c8e62568f345aba0722204dd22d0d149720d00e37712a34a9d2d614e1b854f07d7e89e1eb6e915ca3f90e8e81fb9c2442ed637efdc6b2120153d7
diff --git a/dev-python/virtualenv/virtualenv-20.0.27.ebuild b/dev-python/virtualenv/virtualenv-20.0.27.ebuild
new file mode 100644
index 000000000000..a8a3d84852f0
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.0.27.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6..9}} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/contextlib2-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pathlib2-2.3.3[${PYTHON_USEDEP}]
+ ' -2)
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-0.12[${PYTHON_USEDEP}]
+ ' -2 python3_{6,7} pypy3)
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.0[${PYTHON_USEDEP}]
+ ' -2 python3_6 pypy3)"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-20.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezegun-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.3.4[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ ' 'python3*')
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/towncrier
+
+src_prepare() {
+ # we don't have xonsh
+ rm tests/unit/activation/test_xonsh.py || die
+ # require internet
+ sed -e 's:test_seed_link_via_app_data:_&:' \
+ -i tests/unit/seed/embed/test_boostrap_link_via_app_data.py || die
+ # TODO: investigate
+ sed -e 's:test_cross_major:_&:' \
+ -i tests/unit/create/test_creator.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ # TODO: fix/skip with more granularity tests on pypy3
+ if has "${EPYTHON}" pypy3 python2.7; then
+ einfo "Skipping broken tests on pypy3"
+ continue
+ fi
+
+ distutils_install_for_testing
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}