summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-16 07:38:54 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-16 08:02:01 +0100
commit57fc15b7aa6da25bd172a98823c020774e05621c (patch)
tree9043dff8482d1c4545941fd21bd44e1f9e15886a /dev-python/unearth
parentdev-python/mkdocs-material: Bump to 9.5.4 (diff)
downloadgentoo-57fc15b7aa6da25bd172a98823c020774e05621c.tar.gz
gentoo-57fc15b7aa6da25bd172a98823c020774e05621c.tar.bz2
gentoo-57fc15b7aa6da25bd172a98823c020774e05621c.zip
dev-python/unearth: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest1
-rw-r--r--dev-python/unearth/unearth-0.14.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
index 9b6582feb767..3ec204774409 100644
--- a/dev-python/unearth/Manifest
+++ b/dev-python/unearth/Manifest
@@ -1,2 +1,3 @@
DIST unearth-0.12.1.tar.gz 280628 BLAKE2B 2f96c818f5744b228d11d81fac8fb69da4df685b221f3a77424a1eb1d584e154798974ad4548c6f4264faa98f52cddeb94249e1c7e21136c50c08d97446149b6 SHA512 f726562191a3f2b9c189d16223b86307d79f0ca9e251c155e7acbc92160bed834c78064fbc5d745cd90b84ccd6eb2a24c737018fd670474921db0c7d15480576
DIST unearth-0.13.0.tar.gz 280537 BLAKE2B 92e8cfd42c36d067eccba594ef6e510491156bb4e85d66ab0c1050029be3acf3308c21581d82a3ffd1982d1c8eb966d0be68d1fb8739621b52aa9e7073fd5963 SHA512 48bcdd2e61ffc6580ce19d0124e43aab0411efa913801cd74365ddefa3cec50eb0742997fd6359b6191a00314964b052ebf8d3ea5a173d37bc2cfedc1d030408
+DIST unearth-0.14.0.tar.gz 280614 BLAKE2B d52ca2c8412a0e7bdf5c47d9693b4cdfe3a17ecc95d9d79ecdf7ee0cd5df7518de9cecf8efdfd88ae3f0b852c6bdc8b2c83198e23017d24a47fc6489b1c6e14e SHA512 ab785935f94a1987146471843961a4edc155e135471d4885324d1c2327527f112e03e1146f85a013ad0fd4560f803b616b12618d810becddea94abbce09096c4
diff --git a/dev-python/unearth/unearth-0.14.0.ebuild b/dev-python/unearth/unearth-0.14.0.ebuild
new file mode 100644
index 000000000000..ddcdfe66abda
--- /dev/null
+++ b/dev-python/unearth/unearth-0.14.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver
+}