summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-09 21:44:37 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-09 21:47:06 -0500
commit6ec7fd1505906a225ac484f0b2632b617c85d323 (patch)
treea3106fc2243815b2e7a88288ea0b5e1ead75781b /dev-python/twisted-web
parentsys-kernel/hardened-sources: version bump to 4.8.6 (diff)
downloadgentoo-6ec7fd1505906a225ac484f0b2632b617c85d323.tar.gz
gentoo-6ec7fd1505906a225ac484f0b2632b617c85d323.tar.bz2
gentoo-6ec7fd1505906a225ac484f0b2632b617c85d323.zip
dev-python/twisted: move blockers to RDEPEND
Diffstat (limited to 'dev-python/twisted-web')
-rw-r--r--dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild5
-rw-r--r--dev-python/twisted-web/twisted-web-13.2.0.ebuild5
-rw-r--r--dev-python/twisted-web/twisted-web-15.1.0.ebuild5
-rw-r--r--dev-python/twisted-web/twisted-web-15.2.1.ebuild5
4 files changed, 12 insertions, 8 deletions
diff --git a/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild b/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild
index ab9f1dd662f1..e30c41d1d1b0 100644
--- a/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild
+++ b/dev-python/twisted-web/twisted-web-13.0.0-r1.ebuild
@@ -13,10 +13,11 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-f
IUSE="soap"
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then
diff --git a/dev-python/twisted-web/twisted-web-13.2.0.ebuild b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
index 674840c28e90..ab18fee2d83e 100644
--- a/dev-python/twisted-web/twisted-web-13.2.0.ebuild
+++ b/dev-python/twisted-web/twisted-web-13.2.0.ebuild
@@ -14,11 +14,12 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-f
IUSE="soap"
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then
diff --git a/dev-python/twisted-web/twisted-web-15.1.0.ebuild b/dev-python/twisted-web/twisted-web-15.1.0.ebuild
index 4bb97ff34685..3f8a1576bb24 100644
--- a/dev-python/twisted-web/twisted-web-15.1.0.ebuild
+++ b/dev-python/twisted-web/twisted-web-15.1.0.ebuild
@@ -14,11 +14,12 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x8
IUSE="soap"
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then
diff --git a/dev-python/twisted-web/twisted-web-15.2.1.ebuild b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
index 5035760681e1..29f34756bd71 100644
--- a/dev-python/twisted-web/twisted-web-15.2.1.ebuild
+++ b/dev-python/twisted-web/twisted-web-15.2.1.ebuild
@@ -14,11 +14,12 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-f
IUSE="soap"
DEPEND="
- !dev-python/twisted
=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
soap? ( dev-python/soappy[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/twisted
+"
python_prepare_all() {
if [[ "${EUID}" -eq 0 ]]; then