summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-23 06:51:52 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-23 08:22:10 +0200
commit0c9bdbd2da5dfd525822f3c9bd33133a2540f3a1 (patch)
tree7299980ce5b88a28baf3b51dc84e5b1bfa978ca5 /dev-python/trove-classifiers
parentdev-python/xarray: Bump to 2022.6.0 (diff)
downloadgentoo-0c9bdbd2da5dfd525822f3c9bd33133a2540f3a1.tar.gz
gentoo-0c9bdbd2da5dfd525822f3c9bd33133a2540f3a1.tar.bz2
gentoo-0c9bdbd2da5dfd525822f3c9bd33133a2540f3a1.zip
dev-python/trove-classifiers: Bump to 2022.7.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2022.7.22.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 4132c262b12f..da224792d4c0 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,2 +1,3 @@
DIST trove-classifiers-2022.6.23.gh.tar.gz 14950 BLAKE2B 7203b8edb6f8a8886371a60f3c273b02b7fe045230a3a0c89a7282a896e513535a47fe06834fd6e33b98c480695b69be524dea1402f463f3c82fc80ddf8ac320 SHA512 c2c186b5d13f626a43f29a1eff6ebf2f17f8240af554f27ffdf05b506d428dd59582e7357a85b62f94714e024ae98ea216487726526639371c24c6b46b96df4e
DIST trove-classifiers-2022.6.26.gh.tar.gz 14966 BLAKE2B 360a8a01d710456a7edf2f56ce5ca4645e0f5e79db09087a888556e6555a15fd6f6b0aa3112bf0f6c2652759fce93e76357775ca57e53615dd99c4f1b929303d SHA512 1857d53e7731ada3ca811222bab2d0734da0e18fdf36dcada166bd15b1f397cf8575963d8432eb2d0de571646da6b0b18299af3bb7e44fb225586aa76f6de35f
+DIST trove-classifiers-2022.7.22.gh.tar.gz 14999 BLAKE2B ba6647b8ccb0a8a791d91c48094f3a748866c7f80f92b28903bd09084b7a216b2ba824657ba5f8ef8988edf242140c0b449804f58d3c1522e857670a1f01d455 SHA512 7d60a18a7ee11e21021f5ccc131e9ca28769083776898d931dd92131ea7edecd7ecad17a7a9d6d2d11e19ab8ff6a6fc2373ff9938fc26567e0f7c4a0e903d3c1
diff --git a/dev-python/trove-classifiers/trove-classifiers-2022.7.22.ebuild b/dev-python/trove-classifiers/trove-classifiers-2022.7.22.ebuild
new file mode 100644
index 000000000000..964617661415
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2022.7.22.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}