summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 14:39:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 14:39:44 +0200
commit6cfb3e155b02a948c5907b547c8a59b4ddec3bf0 (patch)
tree55194a1a0030e0bf1d8424ba7be457361ddc6343 /dev-python/trimesh
parentapp-admin/awscli: Bump to 1.25.79 (diff)
downloadgentoo-6cfb3e155b02a948c5907b547c8a59b4ddec3bf0.tar.gz
gentoo-6cfb3e155b02a948c5907b547c8a59b4ddec3bf0.tar.bz2
gentoo-6cfb3e155b02a948c5907b547c8a59b4ddec3bf0.zip
dev-python/trimesh: Bump to 3.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-3.15.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 8e5b0e993d50..0cb2c8a5655f 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,3 +1,4 @@
DIST trimesh-3.13.5.gh.tar.gz 11961925 BLAKE2B 8a4b069f2df49c9ca6121cd3ea446f959a4d5df16b2eafca039b7bc55f04830e054a1c03e012e25594ccda415fedf26b0ab3ae1dbe5e5d1b019bf9e899703169 SHA512 dd4bd7051d48f382ec3e96e55156a6d4cc554a097133d8deb033b9fbcf6f50cf446539484c2a0858243728bc3a7bb6973876919d900a7deb2ff1a6bd11dc397c
DIST trimesh-3.14.0.gh.tar.gz 11962245 BLAKE2B 56ae1d987f43b6945191c80be6ac0a47cad51de370b4d4033baeec69b0aafa54ce4282e622d7f29a4906efde5ce7af2b13b8567b98a519eab8edf791de90f355 SHA512 495f90fe37bbeb339b7db4dbd366bac126a43e956ec18ec77c9ee697e7d8155f0c048f8e5280230684cb602b26a4be1be1e74335db94f4272b50816ab937e2ca
DIST trimesh-3.14.1.gh.tar.gz 11961899 BLAKE2B eab37c94da03cfdefa2f4bff78a1a1cdd2a4c5d3d5da7ef5f462de331c7c2dbaaabbc53a0033ca95a3b4d9d61e072af2f2b689d291e32a89531ca2b5e9d8f8e2 SHA512 e8c43275552d2ddf2e6c1d7582c67f34d7bdaddd5df2cfac9a3758eac12a7fc8bc41748465317eb4e983d7d2d9d51209ab85bfa781022227c0be57618991e9b4
+DIST trimesh-3.15.1.gh.tar.gz 11956148 BLAKE2B 6b0486f779c440baa701f19c5ced085f6f4dcf93704720d8158dc216d1b8e0b46c7549c0adbebee83e34fe2b0eda42da44c61848a9f11bac9d66736566d58c9c SHA512 04459bbb99a1a12cb0a3626d7a1b465b612b7b36690b7c1e6f0dd358794a46a9f64d3465021271846112abc69b0b4f4465bf0b045deb194c28272a4680e65e65
diff --git a/dev-python/trimesh/trimesh-3.15.1.ebuild b/dev-python/trimesh/trimesh-3.15.1.ebuild
new file mode 100644
index 000000000000..11e1a73dfac5
--- /dev/null
+++ b/dev-python/trimesh/trimesh-3.15.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimsh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}