summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 05:43:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 06:06:38 +0100
commit74d486b019c1ad33ee4042603b84afe9bf38350e (patch)
tree0b7061118a9b384fa40e26e008b555f179600183 /dev-python/tld
parentdev-python/jc: Bump to 1.23.0 (diff)
downloadgentoo-74d486b019c1ad33ee4042603b84afe9bf38350e.tar.gz
gentoo-74d486b019c1ad33ee4042603b84afe9bf38350e.tar.bz2
gentoo-74d486b019c1ad33ee4042603b84afe9bf38350e.zip
dev-python/tld: Bump to 0.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tld')
-rw-r--r--dev-python/tld/Manifest1
-rw-r--r--dev-python/tld/tld-0.13.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/tld/Manifest b/dev-python/tld/Manifest
index e0bbd83b0256..769fa0952c76 100644
--- a/dev-python/tld/Manifest
+++ b/dev-python/tld/Manifest
@@ -1,2 +1,3 @@
DIST tld-0.12.6.tar.gz 358405 BLAKE2B cf7bd68f26507cd4ac1c681705d8c495131a8b3aa64115e0259f7ef33f61c5db4911cc8cb1493e901237d401bd4eff4bda9cd687d19d9e1e275c3d87980069ae SHA512 ff10041178976af97c920a519ce3bb5a0a46f4299c24419db9a0502e89296e2bd66885dac5927e940c3abc22d6b390336916622cab771a57ba1c8f0960de2583
DIST tld-0.12.7.gh.tar.gz 444946 BLAKE2B ccd39014b3facdbb836aa33b0daddc819be2ad246985f8bbcd0f13ef01d026c7c9aaeb1cb41312602cf7babe6ec8273c9456a5afb83850f77cd90ad3f9a9b7f9 SHA512 11b573cea770f7aa1ae58f2e6787e62dddd515b2a91b5d4f89e160615b4e3d0d9219f43e3c94251efd3d5b46779390ed66a312ca1751b224284a0765da972b28
+DIST tld-0.13.gh.tar.gz 443877 BLAKE2B 9f84307ce704500096dd2abff75ead534dbd17b59ea0d3dae84394b791aeee873638e6e224ddd3b5c598293a46ead964ae36022b0c3c7411de7c64096d0c69cc SHA512 87157ca2fc8977a96f6289269015bc5a90f3f033fb8ea96552eb8d00d05a346d8f3c61123a311803aa301c735a510a2c0986364f3b2ae4366e2c34aea15b538d
diff --git a/dev-python/tld/tld-0.13.ebuild b/dev-python/tld/tld-0.13.ebuild
new file mode 100644
index 000000000000..cdcf22f36571
--- /dev/null
+++ b/dev-python/tld/tld-0.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract the top level domain (TLD) from the URL given"
+HOMEPAGE="
+ https://github.com/barseghyanartur/tld/
+ https://pypi.org/project/tld/
+"
+SRC_URI="
+ https://github.com/barseghyanartur/tld/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/Faker[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' pytest.ini || die
+}