summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-23 15:11:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-23 18:18:55 +0200
commit0bb9d55439a26a3f74ca2c5303814d039e7c720d (patch)
treee78967dcff576a2062b351c4fb569828c8022e6a /dev-python/tenacity
parentdev-python/resolvelib: Enable py3.13 (diff)
downloadgentoo-0bb9d55439a26a3f74ca2c5303814d039e7c720d.tar.gz
gentoo-0bb9d55439a26a3f74ca2c5303814d039e7c720d.tar.bz2
gentoo-0bb9d55439a26a3f74ca2c5303814d039e7c720d.zip
dev-python/tenacity: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/tenacity-8.4.1.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/dev-python/tenacity/tenacity-8.4.1.ebuild b/dev-python/tenacity/tenacity-8.4.1.ebuild
index 6b916a7dff79..0a802a832cbb 100644
--- a/dev-python/tenacity/tenacity-8.4.1.ebuild
+++ b/dev-python/tenacity/tenacity-8.4.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -21,9 +21,23 @@ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
- >=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]
- dev-python/typeguard[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]
+ dev-python/typeguard[${PYTHON_USEDEP}]
+ ' 3.{10..12})
)
"
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ if ! has_version ">=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_tornado.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}