summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-30 19:27:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-30 20:00:57 +0100
commit509079b52997a15378a0dbd549ad272e85d2a093 (patch)
tree9a69fec615056821cf527fe129646cb11566edd7 /dev-python/taskgroup
parentdev-python/elasticsearch: add 8.10.1 (diff)
downloadgentoo-509079b52997a15378a0dbd549ad272e85d2a093.tar.gz
gentoo-509079b52997a15378a0dbd549ad272e85d2a093.tar.bz2
gentoo-509079b52997a15378a0dbd549ad272e85d2a093.zip
dev-python/taskgroup: New package, v0.0.0_alpha4
New backport required by dev-python/hypercorn, sigh. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/taskgroup')
-rw-r--r--dev-python/taskgroup/Manifest1
-rw-r--r--dev-python/taskgroup/metadata.xml12
-rw-r--r--dev-python/taskgroup/taskgroup-0.0.0_alpha4.ebuild25
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/taskgroup/Manifest b/dev-python/taskgroup/Manifest
new file mode 100644
index 000000000000..91e081575398
--- /dev/null
+++ b/dev-python/taskgroup/Manifest
@@ -0,0 +1 @@
+DIST taskgroup-0.0.0a4.tar.gz 8553 BLAKE2B b9fe9e2442ef8ea5972599a150ad8d2e41004a0aee2112e455d0b850c3833fb266fe2a6b730a4d8371eb3fff0d7101f2803d8708f3f9ea1159338495ca9255be SHA512 fc5a78de3d20fecd82a2c9a142ecf1df8f33f185a792f50b86558d7bb38d49307977a4db0709dbb806cca2a1d3aba46c86833c24973e155c3295437038581ab7
diff --git a/dev-python/taskgroup/metadata.xml b/dev-python/taskgroup/metadata.xml
new file mode 100644
index 000000000000..19dd71f0897d
--- /dev/null
+++ b/dev-python/taskgroup/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">graingert/taskgroup</remote-id>
+ <remote-id type="pypi">taskgroup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/taskgroup/taskgroup-0.0.0_alpha4.ebuild b/dev-python/taskgroup/taskgroup-0.0.0_alpha4.ebuild
new file mode 100644
index 000000000000..67c4cb856cef
--- /dev/null
+++ b/dev-python/taskgroup/taskgroup-0.0.0_alpha4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_10 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of asyncio.TaskGroup, asyncio.Runner and asyncio.timeout"
+HOMEPAGE="
+ https://github.com/graingert/taskgroup/
+ https://pypi.org/project/taskgroup/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ <dev-python/typing-extensions-5[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.8[${PYTHON_USEDEP}]
+"