summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-10 07:06:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-10 07:06:46 +0100
commit6c62e0a2f566290c822df990d92b4ce6e79e05e6 (patch)
tree3dc288defd7bcec5df74426131edf5d0cd6fdcaa /dev-python/starlette
parentdev-python/line_profiler: Bump to 4.0.2 (diff)
downloadgentoo-6c62e0a2f566290c822df990d92b4ce6e79e05e6.tar.gz
gentoo-6c62e0a2f566290c822df990d92b4ce6e79e05e6.tar.bz2
gentoo-6c62e0a2f566290c822df990d92b4ce6e79e05e6.zip
dev-python/starlette: Bump to 0.23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/starlette')
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.23.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index eb0dc7a73fd9..7823dcb70705 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1,2 +1,3 @@
DIST starlette-0.21.0.gh.tar.gz 2830353 BLAKE2B 7ff818d4687757ec8699dcd0e2582af78211787b7a0f2110da045eb4f7a8760262cf144b0af7dc9f72140b5dae1e65f7a4207ee3b165db4091c5139ce0bfcc85 SHA512 c246862604ba807141313857321d898d996eaa771ccb197546d0928a75cbb69f0e485fe90d2c817e70323146077c487436516384e1401d815c59c0ac75845e2b
DIST starlette-0.23.0.gh.tar.gz 2830816 BLAKE2B 38886ef2e586965650a84b091928169b6164bb6931b5ce3289a5f3e38897de9be088ff02432d86176de7006783bf328a3b56659c45a42766e578adfb8c2ddb15 SHA512 fe13ab9a3efafac9a5a44b3471b0e0a02b6012d5336d411d169fb9521ceb23e181a39bda91ed31cd4084628029f7264f277c86a47108ae249bb22b9d9a3c68a5
+DIST starlette-0.23.1.gh.tar.gz 2830865 BLAKE2B b1eaf59421d413179ad294b240babb9b1beabbf10d8364187eb406a3b87a1412b3959b90f44ac1bbada7858c3ffc90560208bc433ca5aaf835dda1766282fe65 SHA512 9af4ab2b2e3af4e7acd2e93a9a4b4f4c8c3b56ba971f7a8faf65308d76a4f30b8ab0ab263535480af614a5082420cafb3d939c7477472710cce9241bd947139b
diff --git a/dev-python/starlette/starlette-0.23.1.ebuild b/dev-python/starlette/starlette-0.23.1.ebuild
new file mode 100644
index 000000000000..ca1a5dd0fabe
--- /dev/null
+++ b/dev-python/starlette/starlette-0.23.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest