summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 08:14:55 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 08:54:23 +0100
commit3e77f7ee6b7a6789d8aff0c45c8daa5c5ed6dd2d (patch)
treeb481797b22f47fc862e2c897c9e798b124074cc8 /dev-python/sqlparse
parentdev-python/sqlglot: Bump to 26.0.0 (diff)
downloadgentoo-3e77f7ee6b7a6789d8aff0c45c8daa5c5ed6dd2d.tar.gz
gentoo-3e77f7ee6b7a6789d8aff0c45c8daa5c5ed6dd2d.tar.bz2
gentoo-3e77f7ee6b7a6789d8aff0c45c8daa5c5ed6dd2d.zip
dev-python/sqlparse: Bump to 0.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlparse')
-rw-r--r--dev-python/sqlparse/Manifest1
-rw-r--r--dev-python/sqlparse/sqlparse-0.5.3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sqlparse/Manifest b/dev-python/sqlparse/Manifest
index 8a28c7bdcaca..a51597243640 100644
--- a/dev-python/sqlparse/Manifest
+++ b/dev-python/sqlparse/Manifest
@@ -1 +1,2 @@
DIST sqlparse-0.5.2.tar.gz 84951 BLAKE2B a270c94bc54de65f7c18549c262e40348cf7961cdd44c33dbcccdc7da59fe89ae1e746982b5f70cf859a2e16ca7721537f976ebce31f9664873c7182ebdf205d SHA512 d674996be8ef89309d73ae924904e3dbe09cfe6d9f2278d5aec43425571a8300785de96efd0936be82e49ec725668c234fd8a4a99b387832c4acce45ef0c8c62
+DIST sqlparse-0.5.3.tar.gz 84999 BLAKE2B 034c19eb1bb057c755a61248dc74c6e114d2bf2633f33d15b4a012ec4734c0374276f0bc8347706f6e48ef13d130c6769ceb9df04f09fabde2cb82bdb819e9a4 SHA512 219c4a3874606b6b3270fb507d89822412b51d8d120d50682fa683ab127fe05538256a575b5b29ee1a9f88be51ad46999e7c2ad2bb84a39e96ae6d2401eaffcd
diff --git a/dev-python/sqlparse/sqlparse-0.5.3.ebuild b/dev-python/sqlparse/sqlparse-0.5.3.ebuild
new file mode 100644
index 000000000000..2f4e3391419b
--- /dev/null
+++ b/dev-python/sqlparse/sqlparse-0.5.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="
+ https://github.com/andialbrecht/sqlparse/
+ https://pypi.org/project/sqlparse/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest