summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-22 07:25:36 +0000
committerSam James <sam@gentoo.org>2023-02-22 07:42:23 +0000
commitedd281e5cb0e65dd6cb2cd64ff7236f057e2120f (patch)
tree51aacba0c0a57eeb02bf85df3609d4d802decaaf /dev-python/sphinx-prompt
parentnet-misc/nyx: enable py3.11 (diff)
downloadgentoo-edd281e5cb0e65dd6cb2cd64ff7236f057e2120f.tar.gz
gentoo-edd281e5cb0e65dd6cb2cd64ff7236f057e2120f.tar.bz2
gentoo-edd281e5cb0e65dd6cb2cd64ff7236f057e2120f.zip
dev-python/sphinx-prompt: lift sphinx restriction in requirements
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-prompt')
-rw-r--r--dev-python/sphinx-prompt/sphinx-prompt-1.6.0-r1.ebuild (renamed from dev-python/sphinx-prompt/sphinx-prompt-1.6.0.ebuild)10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/sphinx-prompt/sphinx-prompt-1.6.0.ebuild b/dev-python/sphinx-prompt/sphinx-prompt-1.6.0-r1.ebuild
index 68cf7b066edc..36ba1e1af0e6 100644
--- a/dev-python/sphinx-prompt/sphinx-prompt-1.6.0.ebuild
+++ b/dev-python/sphinx-prompt/sphinx-prompt-1.6.0-r1.ebuild
@@ -23,7 +23,13 @@ RDEPEND="
distutils_enable_tests pytest
python_prepare_all() {
- # https://github.com/sbrunner/sphinx-prompt/pull/330
- sed -E -i -e "/^version =/s:([0-9.]+):${PV}:" pyproject.toml || die
+ # for Version: https://github.com/sbrunner/sphinx-prompt/pull/330
+ # for Sphinx dep: https://github.com/sbrunner/sphinx-prompt/issues/174
+ # and poetry-plugin-tweak-dependencies-version usage.
+ sed -E -i \
+ -e "/^version =/s:([0-9.]+):${PV}:" \
+ -e "/^Sphinx =/s:([0-9.]+):>=5:" \
+ pyproject.toml || die
+
distutils-r1_python_prepare_all
}