summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 06:32:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 07:16:18 +0200
commit7476e184972648884d2d5fdea237236198d7cbfa (patch)
tree561fa0b8bcc3c0608e518094fc5f15c7cd103dce /dev-python/shellingham
parentapp-admin/awscli: Bump to 1.29.69 (diff)
downloadgentoo-7476e184972648884d2d5fdea237236198d7cbfa.tar.gz
gentoo-7476e184972648884d2d5fdea237236198d7cbfa.tar.bz2
gentoo-7476e184972648884d2d5fdea237236198d7cbfa.zip
dev-python/shellingham: Bump to 1.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/shellingham')
-rw-r--r--dev-python/shellingham/Manifest1
-rw-r--r--dev-python/shellingham/shellingham-1.5.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/shellingham/Manifest b/dev-python/shellingham/Manifest
index 5f50acd7f2ce..f9fd372a8472 100644
--- a/dev-python/shellingham/Manifest
+++ b/dev-python/shellingham/Manifest
@@ -1 +1,2 @@
DIST shellingham-1.5.1.gh.tar.gz 21429 BLAKE2B 19a3258836616e8da2510d1d3af1d9bba5731494e10c5f20a9a50b153b0a9e5892005f9bab0ad5938731457db072acccd3071614ff854ae5ffe13ea406cd10f3 SHA512 764419bb1bf9ac223210b1b01abdb15ff276eb1651d91f0e0ee423ec475100d781149fcf98a43bac5ebb22761a4b775bc669c6e9722d25870dbde50568622242
+DIST shellingham-1.5.4.gh.tar.gz 24276 BLAKE2B 9db0fd5b223fb8c184d9f011dddb1de0873c2084457a88cd97244137bdc5fef398cd649569cfc37b9fc57bf3f76b11643c236bdd5144a31d157884adc30dc8bb SHA512 5a56156add14a5ec9cb55ccf0a268f6c64a3e2fec90301ea31f499131560fa537ca3b3544f18944efac451fa21826114a2bbf3b54140d294d94e7ae890964800
diff --git a/dev-python/shellingham/shellingham-1.5.4.ebuild b/dev-python/shellingham/shellingham-1.5.4.ebuild
new file mode 100644
index 000000000000..fd48227af7f0
--- /dev/null
+++ b/dev-python/shellingham/shellingham-1.5.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tool to Detect Surrounding Shell"
+HOMEPAGE="
+ https://github.com/sarugaku/shellingham/
+ https://pypi.org/project/shellingham/
+"
+# Missing tests in PYPI distribution so we use the GH package
+SRC_URI="
+ https://github.com/sarugaku/shellingham/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest