summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-10 13:56:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-10 14:09:20 +0100
commitba49bdf47b4c50abe55b9abb75e54c639b13dc45 (patch)
treeab08c4b6c97daf4601bbd23798efe0c971a3fc6f /dev-python/segno
parentdev-python/jupyter: enable py3.12 (diff)
downloadgentoo-ba49bdf47b4c50abe55b9abb75e54c639b13dc45.tar.gz
gentoo-ba49bdf47b4c50abe55b9abb75e54c639b13dc45.tar.bz2
gentoo-ba49bdf47b4c50abe55b9abb75e54c639b13dc45.zip
dev-python/segno: New package, v1.5.3
New pure Python QR Code generator, as a dependency for dev-python/fritzconnection. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/segno')
-rw-r--r--dev-python/segno/Manifest1
-rw-r--r--dev-python/segno/metadata.xml12
-rw-r--r--dev-python/segno/segno-1.5.3.ebuild33
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/segno/Manifest b/dev-python/segno/Manifest
new file mode 100644
index 000000000000..65c98752a66e
--- /dev/null
+++ b/dev-python/segno/Manifest
@@ -0,0 +1 @@
+DIST segno-1.5.3.gh.tar.gz 1632842 BLAKE2B 208c21db625bb7f3ace67e05b82988cc1e93e34147fa1cb8f070bad8312924aad8e62089ff6738995a3c725ee3d00bb56478896ab1b94067ce1c4bc58970982a SHA512 bdb933a7f4bac1189533199ac84cb729a3592474644deb0c28007c846d200bb08164052d83fbd6a1a82212401987ab393bfdd294f81360a4a8a0c88182a7623f
diff --git a/dev-python/segno/metadata.xml b/dev-python/segno/metadata.xml
new file mode 100644
index 000000000000..8db4dc82124b
--- /dev/null
+++ b/dev-python/segno/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">heuer/segno</remote-id>
+ <remote-id type="pypi">segno</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/segno/segno-1.5.3.ebuild b/dev-python/segno/segno-1.5.3.ebuild
new file mode 100644
index 000000000000..0baab6f31e45
--- /dev/null
+++ b/dev-python/segno/segno-1.5.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python QR Code and Micro QR Code encoder"
+HOMEPAGE="
+ https://pypi.org/project/segno/
+ https://github.com/heuer/segno/
+"
+SRC_URI="
+ https://github.com/heuer/segno/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pypng[${PYTHON_USEDEP}]
+ dev-python/pyzbar[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest